[SOLVED] Pi-hole web interface only accessable on host

[EDIT: SOLVED]

Incase anyone finds this with the same issue, the solution was to stop being stupid and read the manual
I had to enable the firewall rules as stated in the prerequisites of the install guide, in my specific case running ubuntu 22.04 (i think), I had used only the ufw commands and that got the ip method of accessing the webserver to work http://[SERVER IP]/admin/, not the http://pi.hole/ method though

Setup info:

Libre Computer (Le Potato) AML-S905X-CC
Running Ubuntu Desktop 22.04.3 LTS
Running Wireguard on the SBC with the peers on the Wireguard config having their DNS set to the Wireguard Address of the SBC

Endgoal:

I wanna be able to access the Pi-hole web server and take advantage of Pi-hole filtering on all clients of my Wireguard VPN.

The Problem:

The web server is only accessible on the device Pi-hole is being ran on, le potato, and is not accessible on any devices on the same LAN, or the Wireguard setup

Futile Attempts:

http://pi-hole/
http://192.168.2.1/admin (Wireguard address)
http://192.168.1.163/admin (LAN address)
I've tried on all devices, connected to Wireguard, not connected to Wireguard, connected to LAN, and connected to WAN with Wireguard

Debug Token:

https://tricorder.pi-hole.net/ercM2hST/

What is working: (for entertainment purposes mostly)

The hole part works, the web interface is showing client activity, just I can't exactly add any blocklists when my device running the thing shouldn't even have touched a GUI OS in the first place and is screaming for it's life every time i move my mouse, which is why I really need access to the web server OUTSIDE of the device itself.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.