[SOLVED] Can't see device list on Pi-Hole Admin

#1

Hi, I’ve correctly installed Pi-Hole on my Raspberry, and I’m so happy! It just works, and it does an awesome work, but I’ve a simple question.

Expected Behaviour:

As I’ve configured my DD-WRT Router (IP: 192.168.0.1) to use Pi-Hole as Primary DNS Server (Google is set as 2nd and 3rd DNS Server), I’d expect to see in Pi-Hole admin interface all my devices connected to the network.

Actual Behaviour:

Right now I see 2 clients:

  • localhost
  • 192.168.0.1 <- that’s my router

So I think that request made from my devices are done to the router, that redirects it to Pi-Hole.
I can’t see my clients’ table on Pi-Hole.

Is there a solution? Now it’s working, but I think that I should push Pi-Hole address to clients, instead router’s address…

Thank to anyone! :slight_smile:

#2

You’re probably running into this:

But regarding this:

You may want to consider not doing this as it can adversely affect ad-blocking.

1 Like
#3

Thanks so much @jacob.salmela! :wink:

Yes, my problem was that router was pushing its IP as DNS Resolver, and then forward DNS queries to Pi-Hole.

You’re right, but if I could decide between having internet connection with ads and being totally offline, I’d choose the second one! :slight_smile:
Anyway, in the future my idea is to install Pi-Hole on a Synology NAS in a different location than my home, so I’d have a failover DNS Server (if my primary Pi-Hole fails).

Resolution
In DD-WRT there is a simple and easy checkbox that you have to uncheck for pushing to your devices direct IP of DNS Server(s).
The only thing you have to do is uncheck Use DNSMasq for DNS.
This way, you will NOT use your router as DNS Server, you will directly use Pi-Hole, Google or other IP you specify.

Hope that will help someone!
Thanks to all! :):blush:

1 Like
closed #4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.