Solution for DNS circumvention on ASUS RT-AC1200G+ routers

The issue I am facing:
On my ASUS RT-AC 1200 G+ router the router advertises itself as DNS server leading to circumvention of the Pi-Hole. This is a known problem with ASUS routers, in the IP4 settings the option to shut this down is not available (it is in the IPV-6 section). I tried different solutions but found this one to work perfectly on my router:

This was written for another ASUS router but it gives a simple solution (at least) for the AC-1200 G+ range routers as well. So just check NO in the "automatic connect to DNS" option in the WAN settings stops my router from advertising itselfe.

Might work for you.

Here is an addition, as soon as you implement the above solution your ASUS router will frantically start making connections to what looks like a Microsoft dns-server. As soon as you put this domain in your blocklist this traffic is blocked but you will notice the blocked percentage in your statistics will skyrocket. It looks like every 2 seconds the router is trying to make a connection to this DNS. No negative impact on normal traffic noticed.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.