Slow PiHole

Expected Behaviour:
PiHole Should load allow the browser to load web pages almost instantly

Actual Behaviour:
Some times, not on ever web page, web pages load for more than 30 possibly even 60 seconds

Debug Token:
I have 2 Piholes running for redundancy so PiHole 1's Debug Token="fzbxextqb7" And PiHole 2's Debug Token="sqbd7258r7"

Also I have done some googling and found this script and run it on both PiHoles

IPV6_ADDRESS=$(ip -6 a | grep 'fc|fd' | awk -F " " '{gsub("/[0-9]*",""); print $2}')
echo ${IPV6_ADDRESS}
sed -i.setupVars.bak "/IPV6_ADDRESS/d;" "/etc/pihole/setupVars.conf"
echo "IPV6_ADDRESS=${IPV6_ADDRESS}" >> "/etc/pihole/setupVars.conf"
pihole -g

However I have just now run this script so we'll see if it works out

It may be the typical firewall issue. If you'd be willing to participate in our current beta testing, we'd offer you an alternative blocking method you could try for this situation.

Your talking about ftldns I assume? How could that fix the issue?

Have a look at the README of the FTLDNS branch. Search for a setting called BLOCKINGMODE. Setting this to NXDOMAIN should, at least, resolve the firewall issues. Note that it'll disable the blocking page as a side effect.

I'd rather still have the blocking page as it is helpful to the other people in my household. Did you see anything in the debug log that might be useful?

I'm traveling at the moment and can only look at your debug log tonight. Just thought that this might be a quick hint for you.

What would this do with the firewall to help?

Have you taken a look here? It explains the firewall stuff in detail:

1 Like

Yeah I have checked those 2 articles out I have notified the setupVars.config file using the script provided by the author I ran it as a executable .sh file I tried to modify the iptables but that didn't work either

This setting will not affect your firewall at all. It will cause FTLDNS to don't respond with the Pi-hole's IP any more but instead with NXDOMAIN. Hence, the major difference is that your clients will then not even attempt to establish a connection which could time out.

Would that mean I would lose the whole web interface also? Because I definitely don't want that.

I have changed to the NXDOMAIN setting within FTLDNS as an effort to mitigate 'issues' since enabling HTTPS in lighttpd. Many of the sites blocked end up being HTTPS. The 'pretty page' that Pi-Hole provides doesn't work for them with or without lighttpd HTTPS support. Having this configuration, just changed the browser display from a cert violation to not found. Having no IP returned is a better approach for my setup.

No, the Web interface will work as before, it's just the blocking page that wouldn't be displayed any more. However, as @tomporter518 mentioned, the blocking page cannot be displayed over HTTPS anyways and hence I don't consider this a big loss.

@tomporter518 how's your experience with this new feature?

So far so good, though I only switched a few hours ago. If I notice anything odd, I can open a new thread and describe there. I don't expect there will be any need though.

I haven't yet installed as of yet as I wish to do a clean install to avoid any problems.. How do I install the fltdns branch directly without installing the master branch first?

You do have to install the master branch first as the FTLDNS one installs over the master (it retains the initial pi-hole master settings since the FTLDNS is not released yet as stable).

You can use these instructions once pihole is installed, to switch to the FTLDNS:

Ok I had wondered if it were possible to install the ftldns branch directly but seems like its not possible thanks for the information

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.