Slow and loading problems

Hi All,

I just heard a few days ago about Pi-hole and like the idea of blocking all of those commercials.
So i installed a VM (centos7) mini 64bits version and done the curl thinghy :wink:

I used it on my laptop for dns (used the google dns for upstream dns.) The weird part is that i needed to install dnsmasq? before it was running.... but maybe thats my mistake?
then i disabled selinux and tadaa i can use it and login on the admin page.

But now after 2 days testing i noticed to much load issues.
For example:
going to youtube i got the loading icon but it stays loading a movie and nothing happens. Only after a few more trying i see a movie.

And on more websites i think thats having commercials/banners the page keeps loading.
I know when you block all the commercials pages should load faster but in reality thats not what happens here. I looks like its trying to load it but because of pihole its loading and loading.

My first experience is not that great i hope i done something wrong. I know i can whitelist some sites but the idea is blocking adds/banners/commercials not to whitelist them :wink:

And maybe a totally noob thing to say but what is pihole doing with the banner? is it rejecting or is it making a sort of redirect? in that case it should load alot faster?


Is that VM running at home ?

Have you tried with other devices/PC's ?

If you "Disable" Pihole via the web GUI, do you experience same sort of delays ?
(Better reboot the PC after disabling just to be sure cache is clean and clear browser cache!)

Have you tried another browser ?

What do you mean by "banner" ?
Do you mean the ads ?
Pi-hole replaces the IP address for blocked domains that are on the lists into its own ip address through DNS.
So when a page contains an ad, the ad bit gets redirected to the Pi-hole web daemon (lighttpd) that will show a semi blank page instead of an ad.

Ps. there are many more topics in the forum about this subject.
Try a search to see if can find a solution.

EDIT: added one more question ^

1 Like

Hi DeHakkelaar,

VM is running in my house.
DL380 G6 ESXi 6.5 with Vcenter 6.5
Giving the VM 2GB and 1 core cpu.

Other devices tested is with other disks (i have a MSA2312sa 12 disks) and ssd 512GB disk. I moved also the complete vm to a DL360 G5 but same experience.

I have not disabled it and tested if the delays are there (going todo that)
I have not tryed another browser. (going to try that also. but chrome is my favorite and other users on this network use that to.)
Banner is an advertising image. Advertisers sometimes count banner "views," or the number of times a banner graphic image was downloaded over a period of time.
But ads is oke :slight_smile:

So if Pi-hole is replacing the ip adres of the blocked domains it should be much faster with loading a site..
weird thats totally not the issue here it seams likes its blocking everything and thats the delay i see.

I'm going to install in on my laptop and test it again. Maybe other distribution (ubuntu server instead of centos?)

Thanks for answering!

Aha good old G6.
I run a DL360 G6 pizza box with a Xen hypervisor.

Check logs on the VM as well (syslog & dmesg etc).
And VMware logs too!

1 Like

forget to mention:

I use VM Pfsense as gateway (hot IP internet)
then VM Untangle (home edition) (gets cold IP from gw)

Then a VM pfsense for only DHCP (gives gw and dns ip from untangle.

This is the setup. And what i tryed was using the pi-hole dns.

I also used namebench (dns benchmark) and the dns from untangle is the fastest.


I still need to setup proper stub domain for FW/routing etc.
A LAMP VM is doing that now.

Ps. dont worry bout "2GB and 1 core cpu.".
I know a guy who runs Pihole on one ARM core in KVM and I believe something like 300MB of RAM.

just done with a new VM ubuntu server v17. 1GB ram 1 cpu core. and runs verry smooth!.
300mb used indeed. so dont know if its centos7 with pi-hole or the installation but test that later.
For now its runs verry good!!
I keep you updated.



oke done with testing.

Centos7 installed it again on fresh VM but still got weird delay's. When i use ubuntu-server 17X there is no problem at all.
Conclusion. i use ubuntu-server now.

For now i use the dns on my laptop and found one issue (resolving local adresses (mailserver / webserver etc) but i google that up :).
Thx for helping!


Only the systems that acquire IP via DHCP will be added to dnsmasq's DNS (if use Pi-hole for DHCP).
If you got systems with static IP, the easy way is to add lines in the "/etc/hosts" file on Pi-hole.
Pi-hole's dnsmasq reads this file when it starts at boot.
Saves you the googling :wink:

EDIT: or add "Static DHCP lease" in the Pi-hole web GUI.
Advantage, if one of those systems tries to acquire IP via DHCP, maybe because of mistake or maintenance, it will always popup with the right IP.

Oops, made a mistake with that last comment.
Adding "Static DHCP leases" doesnt give desired effect so the "/etc/hosts" file is the place to be.
But as a safety precaution, I have added all my static IP's as "Static DHCP lease" just in case.
And that way, I have records of all the MAC's.

EDIT: I noticed you mentioned mailserver ... you cant add MX DNS records with the "/etc/hosts" file.
For that, have a look here at the bottom of my posting:

thx for your time dehakkelaar,

I fixed it verry easy with /etc/dnsmasq.conf in there you can put a line:

and so one with other local dns issues like webservers from inside the lan..
With a update it stays intact.
modify the /etc/hosts dint not work here.



Thing is, you have this neat folder "/etc/dnsmasq.d/" and any config file you drop into it will be loaded by dnsmasq.
That way you dont have to touch the dnsmasq.conf file and leave it as is.
A distribution upgrade could overwrite this file if unlucky.

And an "address" line is not the same as a Mail Exchange record that tells which machine(s) is/are responsible for mail in a particular domain.

Did you reboot, or restart the dnsmasq daemon to apply the hosts file changes ?
Adding A or AAAA records through the hosts file is a tested procedure.

hmm dint thought about that. I will test the hosts file. i think i forgot the /flushdns on my laptop :).



I am facing loading issue. Some time it automatically closes the psp can be used as a free tool for solving this loading issue.