Setting pihole ip as router DNS does not work

The issue I am facing:
I have a fresh install of pi-hole on a raspberry-pi 3B+.
If I set its IP address (static) as DNS on my router, I cannot browse the internet anymore, no domain name is resolved (or, at least, it looks like it does not).
Funny thing is that if I set the pi-hole as DNS on my smartphone, well, it works...

I am not sure what other information I can provide to help solving this... just let me know if there is any other information I can provide!

Details about my system:

Router: Easy-Box 904 (https://www.vodafone.de/hilfe/easybox/904-xdsl.html)
Pi-hole Version v5.0
Web Interface Version v5.0
FTL Version v5.0

What I have changed since installing Pi-hole:
Nothing.

You set its IP as DNS server to be distributed via DHCP to the clients? In this case you have to dis/reconnect the clients once to pick up the new settings.
Or did you setup pihole as the upstream DNS server for your router (WAN side)?
Please provide a debug token (pihole -d).

thanks for the reply.
I have set as DNS the IP address of the raspberry-pi where pi-hole is running on the router that connects me to the internet (so to speak, I have replaced 8.8.8.8 with 192.168.2.2), but it does not seem to work. As mentioned if I set that 192.168.2.2 in my smartphone DNS settings all works (pi-hole filters the ads and I can navigate the Internet).

I have been trying to for a DHCP lease on the devices where I was running my tests, with no luck.

this is the debug token: https://tricorder.pi-hole.net/xqgknzuvy2