SafeSearch Not Being Implemented

I am running latest version of Pihole v5.4 in Ubuntu.
I notice that SafeSearch is not being implemented after adding the domain and IP under DNS Records.
I have as domain and as IP, but it doesn't work.

Am I missing anything else?

how do I do this? where do I enter this?
I have tried adding as domain and as IP address under DNS Record section, but that doesn't do anything.

I am running pihole in do I get to that file and what command do I need?

You have replied to a four year old thread. I moved your reply (above) to your related new topic.

Please run from a client


Please upload a debug log and post just the token that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

Hi, sorry I am fairly new to this.. I have generated the debug log, but what do you mean by "just the token"?
Is that just a portion of that list?

When you are asked if you wish to upload the debug log, answer yes. Once the debug log is on our server, you will receive a token (a code that tells us how to find your specific debug log). The screen will look something like this (the token will be different, obviously).


    * The debug log can be uploaded to for sharing with developers only.

[?] Would you like to upload the log? [y/N] y
    * Using curl for transmission.


[✓] Your debug token is:
[i] Logs are deleted 48 hours after upload.


   * Provide the token above to the Pi-hole team for assistance at
   * A local copy of the debug log can be found at: /var/log/pihole_debug.log

got it..
I have also added CNAME

but bing strict mode is not being implemented.

What was the output of this requested command?

Server: pi.hole


CNAMEs only work for those domains for which Pi-hole is authoritative. This is not the case in your situation - that is a public domain over which Pi-hole has no authority.

oh, does that mean I can't implement SafeSearch using Pihole then?

You can but you have to have an A record that Pi-hole would be authoritative for. A CNAME alone will not work.

You can try and see if that is enough.

I've tried that and it still doesn't work...

I also notice that the Pihole is not blocking some websites... for example, I added this block list from github

and pihole is completely ignoring it. I can still access the domains on that list... even if I add them individually.
But, if I add, then it gets blocked. For some reason Pihole is ignoring the ones on that come?

These are not the same.

so do I add the IP under the domain section then?
Where do I add it like it shows there ""?

I don't see anywhere else in pihole do to this.

You added an IP for I showed an IP for

Yeah I have that too.. still doesn't work...

So nothing? - please I need help with this.. what else do I need to do?

If you guys don't know how to force least help me add the block list link I provided prior..
When I try to add the link, I get this message...
This is the link