Router configured but clients using Pi-hole

Expected Behaviour:

I have set up Pi-Hole on a PineA64+ with Armbian Bionic. The Web portal appears to indicate that everything is set up fine. I have configured my ASUS RT-AC58U so that the DNS settings under WAN point to my Pi-Hole box. http://192.168.1.200/admin/network.php reports that my router and 127.0.0.1 are using Pi-Hole. I would expect all clients connecting via the router (i.e. using its DHCP) should be using Pi-Hole. Pi-hole was set up to use OpenDNS which is working for all the clients.

Actual Behaviour:

The Pi-Hole web interfaces says that my clients are not using Pi-hole and adverts are not being blocked. I have tried disconnecting and reconnected to the network so that DNS settings are properly updated.

I have also noticed that not all my clients are appearing in the network overview of Pi-hole.

Debug Token:

https://tricorder.pi-hole.net/fb9yvvlb40

With your configuration (pihole upstream DNS server on your router's WAN side) your clients using pihole, but the query is send

Client >Router >Pihole.

To get Client >Pihole directly, you have to distribute pihole's IP as DNS server via DHCP (which you can set up at your router)

Thanks for that, I thought that it was automatically passed through but I see now that it was not. The following helped me too, https://carlosfelic.io/network/configuring-the-pi-hole-with-asus-routers-merlin-or-johns-fork/