RATE_LIMIT=0/0 not working

Hello, I'm really hoping someone may be able to help.... I added an Apple HomePod Mini and 2x Nanoleaf bulbs to my network last week which introduced Thread. I then immediately started receiving tens of thousands of queries related to the devices from:

_uscan._tcp.openthread.thread.home.arpa
_ptp._tcp.openthread.thread.home.arpa
_pdl-datastream._tcp.openthread.thread.home.arpa
_ipp._tcp.openthread.thread.home.arpa
_scanner._tcp.openthread.thread.home.arpa
_printer._tcp.openthread.thread.home.arpa
_ipps._tcp.openthread.thread.home.arpa
_ippusb._tcp.openthread.thread.home.arpa
_uscans._tcp.openthread.thread.home.arpa

and repeatedly received a rate limit warning:

Client 10.XX.X.X (Router IP) has been rate-limited (current config allows up to 1000 queries in 60 seconds).

I then managed to successfully change the rate limit to RATE_LIMIT=0/0 in the pihole-FTL.conf file which immediately stopped the warnings and limits. I also added the domains to be excluded from the stats. Thankfully all looked well and the percentage blocked climbed back up to the usual ~15% from 0.5% when the Thread queries were being logged.

Yesterday I attempted to set up a Minecraft Server on the same Raspberry Pi. It seemed to install well but all of a sudden I started receiving the rate limit warnings again. I checked the pihole-FTL.conf file and it was still all good showing 0/0. But the warnings kept popping up in the web interface. I then decided to remove the server manually by trashing the Minecraft files and uninstall the Pi-hole and reinstall it. Again it worked fine and I changed the newly created pihole-FTL.conf file to add RATE_LIMIT=0/0. But no, I'm still getting the warnings.

It must be linked to the Minecraft server installation. For reference I followed this guide - How to Install Minecraft Server in Raspberry Pi 4 which was really nice and easy to follow. Does anyone know how the Minecraft server could have interfered with the Pi-hole and somehow override the rate limit changes?

Thanks :slight_smile:

Please upload a debug log and post just the token URL that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

Here you go - https://tricorder.pi-hole.net/wEPsWEYz/

Thanks!

Here's a screenshot of the conf file showing the rate limit successfully entered.

The rate limit is commented out - it is not in effect.

1 Like

I tried it without the #; and it didn’t make any difference.

Ok, I added it again without the #; , rebooted everything and ran another debug log. It displayed like this in the log:

I'll have to wait a little while until the Thread network starts calling home again to check if it worked.

24 hours later and all is still well, no rate limit warnings and all thread queries not being logged.

Thank you jfb for pointing out the obvious :slight_smile: I have no idea what happened. I could have sworn the issue started after the Minecraft Server install and I don't remember editing any pi-hole files at the time but maybe I did.

2 Likes