Query Log on Web Interface returns ERR_CONNECTION_RESET

Hi,

I have setup Pi-Hole on an old Raspberry Pi Zero v1.2 and connected to my network.

The query log page on the web interface doesn't work for me. It keeps waiting for data, and in the end nothing.
When I Inspect the page on Chrome Dev Tools, I see that it is waiting on
http://pi.hole/admin/scripts/pi-hole/js/queries.js
After a few seconds, I see a net::ERR_CONNECTION_RESET 200 (OK) error

This only happens for the Query Page. The dashboard and all other parts of the web interface are working just fine. The Pi-Hole is blocking domains correctly as well. Just no data in the Query Page
My setup has nothing other than Pi-Hole running on the Pi Zero (I wiped and created a brand new install). I have reset almost everything Pi-Hole related also

Is this expected behaviour for a Pi Zero v1.2? Is there anything that I can fix?

Debug Token:

https://tricorder.pi-hole.net/ac394k8esi

Pi-hole v5.1.2
Web Interface v5.1.1
FTL v5.2

No

Is there anything in /var/log/lightppd/error.log ?

This is the entire content:

2020-09-13 00:00:52: (server.c.1759) logfiles cycled UID = 0 PID = 16430
2020-09-13 09:27:48: (server.c.2059) server stopped by UID = 0 PID = 1
2020-09-13 09:28:14: (server.c.1464) server started (lighttpd/1.4.53)
2020-09-13 16:29:51: (mod_fastcgi.c.421) FastCGI-stderr: PHP Warning:  dns_get_record(): A temporary server error occurred. in /var/www/html/pihole/index.php on line 227
2020-09-13 16:29:51: (mod_fastcgi.c.421) FastCGI-stderr: PHP Warning:  array_key_exists() expects parameter 2 to be array, null given in /var/www/html/pihole/index.php on line 228
2020-09-13 16:29:53: (mod_fastcgi.c.421) FastCGI-stderr: PHP Warning:  dns_get_record(): A temporary server error occurred. in /var/www/html/pihole/index.php on line 227
2020-09-13 16:29:53: (mod_fastcgi.c.421) FastCGI-stderr: PHP Warning:  array_key_exists() expects parameter 2 to be array, null given in /var/www/html/pihole/index.php on line 228

The timestamp of the FastCGI-stderr corresponds to the first time I tried to access Query Log after rebooting PiZero

Do you run a different web server on your Pi-hole?

No I don't have anything else. This is literally just only Pi-Hole installed

The OS is Raspberry Pi OS (32-bit) Lite (Buster) if that helps

Can you run

cd /var/www/html/admin
git status

?

On branch master
Your branch is up to date with 'origin/master'.

nothing to commit, working tree clean