Problems with pihole docker image > 2022.02.01

Hi, I´m following up on this post here (sorry, was away for awhile)

It´s still not working and I´m not sure what to do ....

Running on a raspberry pi 3B

uname -a
Linux home-core 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l GNU/Linux

my docker-compose (again)

version: "3"

# More info at https://github.com/pi-hole/docker-pi-hole/ and https://docs.pi-hole.net/
services:
  pihole:
    container_name: pihole
    image: pihole/pihole:2022.02.1
    #image: pihole/pihole
    network_mode: host
    environment:
      TZ: 'Europe/Berlin'
      ServerIP: ${ServerIP}
      WEBPASSWORD: secret
      DNSMASQ_USER: root
    volumes:
       - ./etc-pihole/:/etc/pihole/
       - ./etc-dnsmasq.d/:/etc/dnsmasq.d/
       #- /etc/localtime:/etc/localtime:ro
    dns:
      - 127.0.0.1
      - 1.1.1.1
    cap_add:
      - NET_ADMIN
    restart: unless-stopped

startup log

s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] 01-resolver-resolv: applying...
[fix-attrs.d] 01-resolver-resolv: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 05-changer-uid-gid.sh: executing...
[cont-init.d] 05-changer-uid-gid.sh: exited 0.
[cont-init.d] 20-start.sh: executing...
::: Starting docker specific checks & setup for docker pihole/pihole
cap[cap_sys_nice] not permitted

[i] Installing configs from /etc/.pihole...
[i] Existing dnsmasq.conf found... it is not a Pi-hole file, leaving alone!
[✓] Installed /etc/dnsmasq.d/01-pihole.conf
[✓] Installed /etc/dnsmasq.d/06-rfc6761.conf
Existing DNS servers detected in setupVars.conf. Leaving them alone
::: Pre existing WEBPASSWORD found
DNSMasq binding to default interface: eth0
Added ENV to php:
"TZ" => "Europe/Berlin",
"PIHOLE_DOCKER_TAG" => "2022.05",
"PHP_ERROR_LOG" => "/var/log/lighttpd/error.log",
"ServerIP" => "192.168.1.9",
"CORS_HOSTS" => "",
"VIRTUAL_HOST" => "192.168.1.9",
Using IPv4 and IPv6
::: Preexisting ad list /etc/pihole/adlists.list detected ((exiting setup_blocklists early))
https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts
https://mirror1.malwaredomains.com/files/justdomains
https://s3.amazonaws.com/lists.disconnect.me/simple_tracking.txt
https://s3.amazonaws.com/lists.disconnect.me/simple_ad.txt
::: Testing lighttpd config: Syntax OK
::: All config checks passed, cleared for startup ...
::: Enabling Query Logging
[i] Enabling logging...
[✓] Logging has been enabled!
::: Docker start setup complete
Checking if custom gravity.db is set in /etc/pihole/pihole-FTL.conf
Pi-hole version is v5.10 (Latest: v5.10)
AdminLTE version is v5.12 (Latest: v5.12)
FTL version is v5.15 (Latest: v5.15)
Container tag is: 2022.05
[cont-init.d] 20-start.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
Starting lighttpd
Starting crond
Starting pihole-FTL (no-daemon) as root
[services.d] done.

docker info

Client:
Context: default
Debug Mode: false
Plugins:
app: Docker App (Docker Inc., v0.9.1-beta3)
buildx: Docker Buildx (Docker Inc., v0.8.2-docker)

Server:
Containers: 4
Running: 4
Paused: 0
Stopped: 0
Images: 4
Server Version: 20.10.16
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
userxattr: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Cgroup Version: 1
Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc io.containerd.runc.v2 io.containerd.runtime.v1.linux
Default Runtime: runc
Init Binary: docker-init
containerd version: 212e8b6fa2f44b9c21b2798135fc6fb7c53efc16
runc version: v1.1.1-0-g52de29d
init version: de40ad0
Security Options:
seccomp
Profile: default
Kernel Version: 5.10.103-v7l+
Operating System: Raspbian GNU/Linux 10 (buster)
OSType: linux
Architecture: armv7l
CPUs: 4
Total Memory: 3.749GiB
Name: home-core
ID: XXXX:XULI:VU5J:XXXX:EJHS:OHO7:XXXX:KTFH:HL24:3NU3:XXXX:PA6T
Docker Root Dir: /var/lib/docker
Debug Mode: false
Registry: <too many links in post :frowning: >
Labels:
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No kernel memory TCP limit support
WARNING: No oom kill disable support

And here I am :frowning: .....

really no one ?

That doesn't match with:

Double check what image is actually being used.

Ups, error during reconstruction of error, sorry...

switched back to working image before i copied the "don´t working docker-compose" :frowning:

Just imagine, that

image: pihole/pihole:2022.02.1

was

image: pihole/pihole:latest

..... Sorry for the mistake

Hey,

According to container logs, it seems lighttpd started. Could you check if your server is indeed listening on port 80/TCP (netstat -laputen | grep ':80') for starter ?
If so, what does a local curl request tells you (curl -D - http://127.0.0.1/admin/index.php) ?

Also maybe have a look in lighttpd error log : docker exec -it <containerId> cat /var/log/lighttpd/error.log.

Subsidiary question : How are you trying to access WebUI ? Directy or through an HTTP proxy ? On IP address or specific hostname ?
You can also hit F12 in your browser to open developper console and check the networking tab.

Edit : I see you're using envvar "ServerIP: ${ServerIP}". According to documentation, this address determines lighttpd binding address; Yours is apparently "192.168.1.9". You might want to ensure your server is reachable on this interface, or change it to 0.0.0.0. Also perhaps have a look on your firewall rules.