# Podman caching not working

**URL:** https://discourse.pi-hole.net/t/podman-caching-not-working/51742
**Category:** Help
**Created:** [December 20, 2021, 3:05am UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742 "2021-12-20T03:05:53Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![huramentzefix](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/h/6f9a4e/32.png) [@huramentzefix](https://discourse.pi-hole.net/u/huramentzefix)
#### Post date: [December 20, 2021, 3:05am UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742/1 "2021-12-20T03:05:53Z")

</div>

it seems that my DNS cache in pihole is not working.  
When I visit previously already resolved DN's then I get horrible resolve times of around 200ms (which is explainable because of the internetsituation that I am in).

One reason was to get pihole to speed up these ultra slow response times.  
But if I open a previously opened site then I get the same horrible times.

I can not find in my podman enviroment where I could change settings so that I could check or configure the DNS cache.

{"cacheinfo":{"cache-size":10000,"cache-live-freed":0,"cache-inserted":24153,"ipv4":61,"ipv6":43,"srv":0,"cname":51,"ds":0,"dnskey":0,"other":0,"expired":26,"immortal":23}}

when I go into Recent Queries (showing up to 100 queries), [show all] ([http://pi.hole/admin/queries.php?all](http://pi.hole/admin/queries.php?all)) "query log" and then click on "show all queries" I get the following message:  
An unknown error occurred while loading the data.  
But it is not showing any data in there.

Can someone please guide me in the right direction?

---

<div class="post-metadata">

### Author: ![yubiuser](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/yubiuser/32/12100_2.png) [@yubiuser](https://discourse.pi-hole.net/u/yubiuser)
#### Post date: [December 20, 2021, 5:58am UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742/2 "2021-12-20T05:58:13Z")

</div>

Please upload a debug log and post **just the token URL** that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

```auto
pihole -d

```

or do it through the Web interface:

_ **Tools \> Generate Debug Log** _

---

<div class="post-metadata">

### Author: ![huramentzefix](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/h/6f9a4e/32.png) [@huramentzefix](https://discourse.pi-hole.net/u/huramentzefix)
#### Post date: [December 20, 2021, 11:09am UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742/3 "2021-12-20T11:09:24Z")

</div>

yubiuser thank you for your help.  
please see here:

[✓] \*\* FINISHED DEBUGGING! \*\*

```
* The debug log can be uploaded to tricorder.pi-hole.net for sharing with developers only.

```

[i] Debug script running in automated mode  
\* Using curl for transmission.  
\* curl failed, contact Pi-hole support for assistance.  
\* Error message: curl: (60) SSL certificate problem: certificate is not yet valid  
More details here: [https://curl.haxx.se/docs/sslcerts.html](https://curl.haxx.se/docs/sslcerts.html)

curl failed to verify the legitimacy of the server and therefore could not  
establish a secure connection to it. To learn more about this situation and  
how to fix it, please visit the web page mentioned above.

[✗] There was an error uploading your debug log.

- Please try again or contact the Pi-hole team for assistance.
- A local copy of the debug log can be found at: /var/log/pihole\_debug.log

---

<div class="post-metadata">

### Author: ![huramentzefix](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/h/6f9a4e/32.png) [@huramentzefix](https://discourse.pi-hole.net/u/huramentzefix)
#### Post date: [December 20, 2021, 11:33am UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742/4 "2021-12-20T11:33:17Z")

</div>

/etc/dnsmasq.d/01-pihole.conf is not existing. there is no 01-pihole.conf in dnsmasq.d

/etc/pihole/ doesn't exist

/etc/dnsmasq.d/05-pihole-custom-cname.conf doesn't exist when I SSL into it, but the log file shows entries here.

(mod\_fastcgi.c.421) FastCGI-stderr: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in /var/www/html/admin/api\_FTL.php on line 325

---

<div class="post-metadata">

### Author: ![yubiuser](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/yubiuser/32/12100_2.png) [@yubiuser](https://discourse.pi-hole.net/u/yubiuser)
#### Post date: [December 21, 2021, 5:56am UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742/5 "2021-12-21T05:56:31Z")

</div>

> [@huramentzefix](#):
>
> /etc/dnsmasq.d/01-pihole.conf is not existing. there is no 01-pihole.conf in dnsmasq.d
> 
> /etc/pihole/ doesn't exist

How did you install Pi-hole? Is this a docker installation?

* * *

> [@huramentzefix](#):
>
> (mod\_fastcgi.c.421) FastCGI-stderr: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in /var/www/html/admin/api\_FTL.php on line 325

PHP runs out of memory.

> [@How do I increase PHP's memory?](https://discourse.pi-hole.net/t/how-do-i-increase-phps-memory/37170):
>
> I got the same error, while trying to query for the last 7 days. [image] The logs show this: [image] The computer has 2GB. There is 1.3GB available: [image] There is also a lot of swap available: [image] Here is my debug token if helps [https://tricorder.pi-hole.net/pv8rsyd4lh](https://tricorder.pi-hole.net/pv8rsyd4lh)

---

<div class="post-metadata">

### Author: ![huramentzefix](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/h/6f9a4e/32.png) [@huramentzefix](https://discourse.pi-hole.net/u/huramentzefix)
#### Post date: [December 21, 2021, 7:41pm UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742/6 "2021-12-21T19:41:28Z")

</div>

thanks,  
correct, it's a docker install  
opensuse on Pi 3B+

with **find** / -name " **php.ini**" I get several results of the php.ini  
which one is it where I have to increase it to 512M and then restart the lighttpd?

---

<div class="post-metadata">

### Author: ![yubiuser](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/yubiuser/32/12100_2.png) [@yubiuser](https://discourse.pi-hole.net/u/yubiuser)
#### Post date: [December 26, 2021, 8:55pm UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742/7 "2021-12-26T20:55:23Z")

</div>

If never changed this in docker, but on bare metal you should look for the one in the `/cgi/` dir.

---

<div class="post-metadata">

### Author: ![system](https://discourse.pi-hole.net/uploads/default/original/3X/7/c/7c8792f649eeb921c5d2b4c41564ffa873d9a2b8.png) [@system](https://discourse.pi-hole.net/u/system)
#### Post date: [January 16, 2022, 8:55pm UTC](https://discourse.pi-hole.net/t/podman-caching-not-working/51742/8 "2022-01-16T20:55:26Z")

</div>

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.
