Pihole works on iphone when having secondary DNS but

#1

Ok so my pihole seems to be working fine on the PC when having a secondary DNS, but cant say the same for my iPhone. For example when I went to a few sites the ads still showed up I found online that you should only have the pihole as the primary DNS and delete the secondary as ads will still get through, but now webpages are stuck on a white screen loop then says safari could not open the page because the server stopped responding.

Expected Behaviour:

[Webpages should load]

Actual Behaviour:

[Webpage stuck on white loading screen on iphone]

Debug Token:

[https://tricorder.pi-hole.net/pene1df0fi!]

0 Likes

#2

There should be no secondary DNS. All DNS traffic should go to Pi-Hole, with no other option available.

Your debug log shows that there is a mis-match between the IP assigned to the Pi and the IP to which Pi-Hole is assigned to listen. The assigned IP is 76 (on wireless), but Pi-Hole is listening on 75. Check your router for the IP of the Pi, note that IP and then reconfigure Pi-Hole for that interface and IP.

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the wlan0 interface:
   192.168.0.76/24 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   192.168.0.75/24 matches the IP found in /etc/pihole/setupVars.conf
0 Likes

#3

Thank you that fixed it!

0 Likes

closed #4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes