Pihole + wireguard DNS not responding

The issue I am facing:
when my DNS is set to pihole, it doesn't resolve DNS requests. I'm quite new to all this and have tried following several tutorials and other suggestions from this discourse and the pihole documentation but not to much luck.

Details about my system:
I'm using wireguard, without a docker on a raspberry pi 4
https://tricorder.pi-hole.net/XcdYc4Yv/

What I have changed since installing Pi-hole:
I followed the pihole docs to setup wireguard
https://docs.pi-hole.net/guides/vpn/wireguard/server/

Let me know if there's any more information that would be helpful

That doesn't seem to be the case.

Instead, it would seem you have been using some third-party tools that conflict with Pi-hole's configuration, by restricting it to consider only your wireguard interface:

*** [ DIAGNOSING ]: contents of /etc/dnsmasq.d

-rw-r--r-- 1 root root 52 Sep 22 17:14 /etc/dnsmasq.d/02-pivpn.conf
   addn-hosts=/etc/pivpn/hosts.wireguard
   interface=wg0
*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the wg0 interface:
    10.100.0.1/24

[✓] IPv6 address(es) bound to the wg0 interface:
    fd08:4711::1/64
*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✗] Failed to resolve www.d3h3emqn8ms7rt.cloudfront.net on eth0 (192.168.1.28)
[✓] www.d3h3emqn8ms7rt.cloudfront.net is 0.0.0.0 on wg0 (10.100.0.1)

Revisit your third-party tool documentation for support and information on the intended effect of that 02-pivpn.conf.

Meanwhile, to get Pi-hole working, remove that conflicting interface line.
Then run

pihole restartdns
2 Likes

That worked :+1: I have no idea where that setting came from. Thank you so much