PiHole upgrase 5.2.4 to v5.5

My Pihole upgrade failed at the FTL stage

I am new to linux and using a pi II have been running pihole for a while saw the upgrade notification and had a go using "pihole -u"
I have followed the instructions but FTL still does not update. Please help

Expected Behaviour:

pihole updates :slight_smile:

Actual Behaviour:

pihole -v
Pi-hole version is v5.2.4 (Latest: v5.5)
AdminLTE version is v5.4 (Latest: v5.7)
FTL version is v5.7 (Latest: v5.10.2)

sudo pihole -up
[i] Checking for updates...
[i] Pi-hole Core: update available
[i] Web Interface: update available
[i] FTL: update available

[i] Pi-hole core files out of date, updating local repo.
[✓] Check for existing repository in /etc/.pihole
[i] Update repo in /etc/.pihole...HEAD is now at dad6247 Merge pull request #4347 from pi-hole/development
[✓] Update repo in /etc/.pihole

[i] If you had made any changes in '/etc/.pihole/', they have been stashed using 'git stash'

[i] Pi-hole Web Admin files out of date, updating local repo.
[✓] Check for existing repository in /var/www/html/admin
[i] Update repo in /var/www/html/admin...HEAD is now at 50f43bd Merge pull request #1901 from pi-hole/devel
[✓] Update repo in /var/www/html/admin

[i] If you had made any changes in '/var/www/html/admin/', they have been stashed using 'git stash'

[i] FTL out of date, it will be updated by the installer.

[✓] Root user check

    .;;,.
    .ccccc:,.
     :cccclll:.      ..,,
      :ccccclll.   ;ooodc
       'ccll:;ll .oooodc
         .;cll.;;looo:.
             .. ','.
            .',,,,,,'.
          .',,,,,,,,,,.
        .',,,,,,,,,,,,....
      ....''',,,,,,,'.......
    .........  ....  .........
    ..........      ..........
    ..........      ..........
    .........  ....  .........
      ........,,,,,,,'......
        ....',,,,,,,,,,,,.
           .',,,,,,,,,'.
            .',,,,,,'.
              ..'''.

[✗] Update local cache of available packages
Error: Unable to update package cache. Please try "sudo apt-get update"
Unable to complete update, please contact Pi-hole Support

sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Hit:3 http://packages.microsoft.com/repos/code stable InRelease
Reading package lists... Done
E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

Debug Token:

https://tricorder.pi-hole.net/YLHP4nKh/

See Can't update to FTL 5.9 Final: "Error: Unable to update package cache."

1 Like

Result!!

Thanks that did the trick... told you I was new to all this