# Pihole update failed

**URL:** https://discourse.pi-hole.net/t/pihole-update-failed/57744
**Category:** Community Help
**Created:** [September 9, 2022, 12:10am UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744 "2022-09-09T00:10:54Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![mangus580](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/mangus580/32/32479_2.png) [@mangus580](https://discourse.pi-hole.net/u/mangus580)
#### Post date: [September 9, 2022, 12:10am UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/1 "2022-09-09T00:10:54Z")

</div>

**The issue I am facing:**  
pihole-FTL not starting after update

**Details about my system:**  
VMware virtual machine running centos 8.5 (just upgraded from 7)

**What I have changed since installing Pi-hole:**  
Went to update Pihole, and was told I needed to upgrade the base OS first. Upgraded centos from 7 to 8.5, then updated pihole and now it shows the following at the end of the update:

[i] Installing latest logrotate script...  
[i] Existing logrotate file found. No changes made.  
[i] Backing up /etc/dnsmasq.conf to /etc/dnsmasq.conf.old  
[âœ“] man pages installed and database updated  
[i] Testing if systemd-resolved is enabled  
[i] Systemd-resolved is not enabled  
[âœ“] Restarting lighttpd service...  
[âœ“] Enabling lighttpd service to start on reboot...  
[i] Restarting services...  
[âœ“] Enabling pihole-FTL service to start on reboot...  
[i] Restarting pihole-FTL service...  
Unable to complete update, please contact Pi-hole Support

debug token can be found here - [https://tricorder.pi-hole.net/8bljS0mj/](https://tricorder.pi-hole.net/8bljS0mj/)

---

<div class="post-metadata">

### Author: ![rdwebdesign](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/rdwebdesign/32/51363_2.png) [@rdwebdesign](https://discourse.pi-hole.net/u/rdwebdesign)
#### Post date: [September 9, 2022, 12:19am UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/2 "2022-09-09T00:19:12Z")

</div>

Your debug log shows:

```auto
Sep 08 20:02:54 pi-hole pihole-FTL[4069]: /usr/bin/pihole-FTL: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by /usr/bin/pihole-FTL)

```

---

<div class="post-metadata">

### Author: ![mangus580](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/mangus580/32/32479_2.png) [@mangus580](https://discourse.pi-hole.net/u/mangus580)
#### Post date: [September 9, 2022, 12:20am UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/3 "2022-09-09T00:20:13Z")

</div>

suggestions on how to fix that?

---

<div class="post-metadata">

### Author: ![rdwebdesign](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/rdwebdesign/32/51363_2.png) [@rdwebdesign](https://discourse.pi-hole.net/u/rdwebdesign)
#### Post date: [September 9, 2022, 12:25am UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/4 "2022-09-09T00:25:42Z")

</div>

This is an old version of the library and recent Operating Systems usually use a newer version, but I don't know if Centos 8 has the correct library.

Maybe you can find a solution reading other comments:  
[https://discourse.pi-hole.net/search?q=glibc\_2.28](https://discourse.pi-hole.net/search?q=glibc_2.28)

---

<div class="post-metadata">

### Author: ![mangus580](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/mangus580/32/32479_2.png) [@mangus580](https://discourse.pi-hole.net/u/mangus580)
#### Post date: [September 9, 2022, 1:10am UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/5 "2022-09-09T01:10:35Z")

</div>

Awesome - require an OS that doesnt even support the correct libraries.... _sigh_ and people wonder why I never update my crap.

Looks like its likely time to wipe it clean and start over with a different base OS......

---

<div class="post-metadata">

### Author: ![rdwebdesign](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/rdwebdesign/32/51363_2.png) [@rdwebdesign](https://discourse.pi-hole.net/u/rdwebdesign)
#### Post date: [September 9, 2022, 1:28am UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/6 "2022-09-09T01:28:36Z")

</div>

Pi-hole supports Centos Stream 8.  
Centos 8 is not supported anymore by Centos/Red Hat.

You can try the docker image.

---

<div class="post-metadata">

### Author: ![DanSchaper](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/danschaper/32/91_2.png) [@DanSchaper](https://discourse.pi-hole.net/u/DanSchaper)
#### Post date: [September 9, 2022, 4:16am UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/7 "2022-09-09T04:16:02Z")

</div>

> [@mangus580](#):
>
> Upgraded centos from 7 to 8.5

How did you do that process?

---

<div class="post-metadata">

### Author: ![nwebi](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/n/87869e/32.png) [@nwebi](https://discourse.pi-hole.net/u/nwebi)
#### Post date: [September 9, 2022, 9:27pm UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/8 "2022-09-09T21:27:30Z")

</div>

> [@/lib/x86\_64-linux-gnu/libc.so.6: version \`GLIBC\_2.28' not found](https://discourse.pi-hole.net/t/lib-x86-64-linux-gnu-libc-so-6-version-glibc-2-28-not-found/57506):
>
> I am running PI-hole in a VM under Truenas 13 - just upgraded from 12 to 13 proceeded to update pihole by logging in. Here is the messages for the execution of the upgrade. tony@pihole01:~$ pihole -up [✓] Update local cache of available packages [i] Existing PHP installation detected : PHP version 7.2.24-0ubuntu0.18.04.12 [✓] Checking for git [✓] Checking for iproute2 [✓] Checking for dialog [✓] Checking for ca-certificates [i] Checking for updates... [i] Pi-hole Core: up…

---

<div class="post-metadata">

### Author: ![system](https://discourse.pi-hole.net/uploads/default/original/3X/7/c/7c8792f649eeb921c5d2b4c41564ffa873d9a2b8.png) [@system](https://discourse.pi-hole.net/u/system)
#### Post date: [September 30, 2022, 9:27pm UTC](https://discourse.pi-hole.net/t/pihole-update-failed/57744/9 "2022-09-30T21:27:33Z")

</div>

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.
