Pihole + pivpn. static ip's stop dns and ftl

Please follow the below template, it will help us to help you!

Expected Behaviour:

assigning a static ip to a device not stopping dns and ftl

Actual Behaviour:

static ip’s stopping dns and ftl

Debug Token:

not available because it cant upload it

You’ll need to explain or provide some kind of information for us to help you with.

I have pivpn and pihole working together. As sson as i assign a static ip to a device dns and ftl stop running until i remove the static ip. After running ‘ sudo systemctl status --full --no-pager pihole-FTL.service ‘ i see that the ip is already in use.

● pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated)
   Active: active (exited) since Tue 2020-01-14 19:18:11 CET; 39s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 7526 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)

Jan 14 19:18:10 raspberrypi systemd[1]: Starting LSB: pihole-FTL daemon...
Jan 14 19:18:10 raspberrypi pihole-FTL[7526]: Not running
Jan 14 19:18:10 raspberrypi su[7570]: (to pihole) root on none
Jan 14 19:18:10 raspberrypi su[7570]: pam_unix(su:session): session opened for user pihole by (uid=0)
Jan 14 19:18:10 raspberrypi pihole-FTL[7526]: dnsmasq: duplicate dhcp-host IP address 192.168.178.192 at line 23 of /etc/dnsmasq.d/04-pihole-static-dhcp.conf
Jan 14 19:18:10 raspberrypi su[7570]: pam_unix(su:session): session closed for user pihole
Jan 14 19:18:11 raspberrypi systemd[1]: Started LSB: pihole-FTL daemon.

Check /etc/dnsmasq.d/04-pihole-static-dhcp.conf and remove any duplicates.

There arent any. The other 22 lines are all commented because i couldnt figure out what was wrong

This will temporarily reset the nameserver on the Pi to bypass Pi-Hole DNS to allow you to upload a debug log.

sudo nano /etc/resolv.conf

edit nameserver 127.0.0.1 to nameserver 9.9.9.9 or your preferred third party DNS service, save and exit

Run pihole -d and upload the debug log

you got somewhere for me to upload the log? because it still cant upload it

copy and paste the entire log into a reply, and I will quickly make it private.

im getting a problem because im a new user i cant put in more than 5 urls. and the log contains more

here’s a onedrive link to it: (link removed by moderator)

Got it and deleted the link from your post.

It doesn’t appear the pihole-FTL is running; it should be on port 53.

*** [ DIAGNOSING ]: Ports in use
*:5900 vncserver- (IPv6)
*:5900 vncserver- (IPv4)
*:22 sshd (IPv4)
*:22 sshd (IPv6)
*:80 is in use by lighttpd
*:80 is in use by lighttpd

Let’s check all your ports for activity - what is the output of these commands from the Pi terminal:

sudo service pihole-FTL status

sudo netstat -nltup | grep 'Proto\|:53 \|:5053 \|:5353 \|:8953 \|:67 \|:80 \|:471'

● pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated)
   Active: active (exited) since Tue 2020-01-14 19:39:47 CET; 24min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 15702 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)

Jan 14 19:39:46 raspberrypi systemd[1]: Starting LSB: pihole-FTL daemon...
Jan 14 19:39:46 raspberrypi pihole-FTL[15702]: Not running
Jan 14 19:39:46 raspberrypi su[15733]: (to pihole) root on none
Jan 14 19:39:46 raspberrypi su[15733]: pam_unix(su:session): session opened for user pihole by (uid=0)
Jan 14 19:39:47 raspberrypi pihole-FTL[15702]: FTL started!
Jan 14 19:39:47 raspberrypi su[15733]: pam_unix(su:session): session closed for user pihole
Jan 14 19:39:47 raspberrypi systemd[1]: Started LSB: pihole-FTL daemon.
sudo netstat -nltup | grep 'Proto\|:53 \|:5053 \|:5353 \|:8953 \|:67 \|:80 \|:471'
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 127.0.0.1:4711          0.0.0.0:*               LISTEN      15755/pihole-FTL    
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      606/lighttpd        
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN      15755/pihole-FTL    
tcp6       0      0 ::1:4711                :::*                    LISTEN      15755/pihole-FTL    
tcp6       0      0 :::80                   :::*                    LISTEN      606/lighttpd        
tcp6       0      0 :::53                   :::*                    LISTEN      15755/pihole-FTL    
udp        0      0 0.0.0.0:53              0.0.0.0:*                           15755/pihole-FTL    
udp        0      0 0.0.0.0:67              0.0.0.0:*                           15755/pihole-FTL    
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           373/avahi-daemon: r 
udp6       0      0 :::53                   :::*                                15755/pihole-FTL    
udp6       0      0 :::5353

From the Pi terrminal, what is the output of the following:

nslookup pi.hole

nslookup flurry.com

nslookup flurry.com 1.1.1.1

Edit, also include this command output:

sudo grep -v '#\|^$' -R /etc/dnsmasq.*

turning urls into text.

nslookup pi.hole

Server:		127.0.0.1
Address:	127.0.0.1#53

Name:	pi.hole
Address: 192.168.178.100
Name:	pi.hole
Address: 2001:1c01:40ce:9a00:e8ad:cecc:8318:d5f8

nslookup flurry .com

Server:		127.0.0.1
Address:	127.0.0.1#53

Name:	flurry .com
Address: 0.0.0.0
Name:	flurry .com
Address: ::

nslookup flurry .com 1.1.1.1

Server:		1.1.1.1
Address:	1.1.1.1#53

Non-authoritative answer:
Name:	flurry .com
Address: 212.82.100.153
Name:	flurry .com
Address: 74.6.136.153
Name:	flurry .com
Address: 98.136.103.26

sudo grep -v '#\|^$' -R /etc/dnsmasq.*

/etc/dnsmasq.conf:conf-dir=/etc/dnsmasq.d
/etc/dnsmasq.conf.old:conf-dir=/etc/dnsmasq.d
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:googlesdns1,6,8.8.8.8
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:googlesdns2,6,8.8.4.4
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:opendns1,6,208.67.222.220
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:opendns2,6,208.67.222.222
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:opendns3,6,208.67.222.123
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:opendns4,6,208.67.220.123
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:Level3DNS1,6,4.2.2.1
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:Level3DNS2,6,4.2.2.2
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:ComodoSecureDNS,6,8.26.56.26
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:ComodoSecureDNS,6,8.20.247.20
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:norton1,6,199.85.126.10
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:norton2,6,199.85.127.10
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:norton3,6,199.85.126.20
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:norton4,6,199.85.127.20
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:norton5,6,199.85.126.30
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:norton6,6,199.85.127.30
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-option=tag:googlesdns1,6,8.8.8.8
/etc/dnsmasq.d/98-kspr-work.conf:dhcp-host=f0:d5:bf:dc:7f:2b,set:googlesdns1
/etc/dnsmasq.d/02-pihole-dhcp.conf:dhcp-authoritative
/etc/dnsmasq.d/02-pihole-dhcp.conf:dhcp-range=192.168.178.191,192.168.178.251,24h
/etc/dnsmasq.d/02-pihole-dhcp.conf:dhcp-option=option:router,192.168.178.1
/etc/dnsmasq.d/02-pihole-dhcp.conf:dhcp-leasefile=/etc/pihole/dhcp.leases
/etc/dnsmasq.d/02-pihole-dhcp.conf:domain=lan
/etc/dnsmasq.d/02-pihole-dhcp.conf:dhcp-option=option6:dns-server,[::]
/etc/dnsmasq.d/02-pihole-dhcp.conf:dhcp-range=::100,::1ff,constructor:eth0,ra-names,slaac,24h
/etc/dnsmasq.d/02-pihole-dhcp.conf:ra-param=*,0,0
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/gravity.list
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/black.list
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/local.list
/etc/dnsmasq.d/01-pihole.conf:localise-queries
/etc/dnsmasq.d/01-pihole.conf:no-resolv
/etc/dnsmasq.d/01-pihole.conf:cache-size=10000
/etc/dnsmasq.d/01-pihole.conf:log-queries
/etc/dnsmasq.d/01-pihole.conf:log-facility=/var/log/pihole.log
/etc/dnsmasq.d/01-pihole.conf:local-ttl=2
/etc/dnsmasq.d/01-pihole.conf:log-async
/etc/dnsmasq.d/01-pihole.conf:server=208.67.222.222
/etc/dnsmasq.d/01-pihole.conf:server=208.67.220.220
/etc/dnsmasq.d/01-pihole.conf:server=2620:119:35::35
/etc/dnsmasq.d/01-pihole.conf:server=2620:119:53::53
/etc/dnsmasq.d/01-pihole.conf:domain-needed
/etc/dnsmasq.d/01-pihole.conf:bogus-priv
/etc/dnsmasq.d/01-pihole.conf:host-record=dns.reinder-stegen.com,192.168.178.100
/etc/dnsmasq.d/01-pihole.conf:except-interface=nonexisting
/etc/dnsmasq.d/01-pihole.conf:dhcp-name-match=set:hostname-ignore,wpad
/etc/dnsmasq.d/01-pihole.conf:dhcp-name-match=set:hostname-ignore,localhost
/etc/dnsmasq.d/01-pihole.conf:dhcp-ignore-names=tag:hostname-ignore
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=00:5B:94:9D:26:72,192.168.178.15,reinders-iPad
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=9C:30:5B:59:24:D5,192.168.178.192,R-Inspirion
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=EC:8C:9A:9C:8E:B4,192.168.178.193,Huawei_Reinder
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=B8:8A:EC:F5:F5:2D,192.168.178.194,Nintendo_Switch
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=64:5A:04:C6:8A:5A,192.168.178.207,Laptop_KSPR
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=F0:D5:BF:DC:7F:2B,192.168.178.208,Work_KSPR
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=80:4E:70:89:B5:26,192.168.178.209,Samsung_KSPR
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=2C:4D:79:41:39:CD,192.168.178.210,Wahoo-Bolt
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=EC:8C:9A:9C:8D:D0,192.168.178.218,Huawei_Sieger
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=F8:46:1C:0D:CD:22,192.168.178.219,PS4_Pro
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=90:2E:1C:70:73:D5,192.168.178.220,Chromebook_Sieger
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=EC:5C:68:25:D9:DB,192.168.178.229,Laptop_Sara
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=64:C2:DE:1D:1C:D4,192.168.178.230,LG_Sara
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=AC:22:05:F2:1E:CA,Modem
/etc/dnsmasq.d/04-pihole-static-dhcp.conf.save:dhcp-host=54:2A:A2:8F:2C:0C,192.168.178.240,Philips_Tv

With your existing configuration as posted in your recent reply, what is the output of

sudo service pihole-FTL status

pihole-FTL dnsmasq-test

And, are you still experiencing the same problem in this configuration?

● pihole-FTL.service - LSB: pihole-FTL daemon
Loaded: loaded (/etc/init.d/pihole-FTL; generated)
Active: active (exited) since Wed 2020-01-15 06:26:51 CET; 50min ago
Docs: man:systemd-sysv-generator(8)
Tasks: 0 (limit: 4915)
Memory: 0B
CGroup: /system.slice/pihole-FTL.service

Jan 15 06:26:50 raspberrypi systemd[1]: Starting LSB: pihole-FTL daemon…
Jan 15 06:26:50 raspberrypi pihole-FTL[314]: Not running
Jan 15 06:26:51 raspberrypi su[361]: (to pihole) root on none
Jan 15 06:26:51 raspberrypi su[361]: pam_unix(su:session): session opened for user pihole by (uid=0)
Jan 15 06:26:51 raspberrypi pihole-FTL[314]: FTL started!
Jan 15 06:26:51 raspberrypi su[361]: pam_unix(su:session): session closed for user pihole
Jan 15 06:26:51 raspberrypi systemd[1]: Started LSB: pihole-FTL daemon.

pihole-FTL dnsmasq-test
dnsmasq: syntax check OK.

im not experiencing the same problem anymore, but only because im not using static ip’s at the moment

Are you certain? You have static IP’S listed in a configuration file inside /etc/dnsmasq.d. I don’t believe Linux reads the file extension to see if the file should be used. Thus, all files in the directory are used.

yes im sure because one file is a backup file and the other has every line commented. and if i was using static ip’s i would see that

Please post the complete contents of any files in /etc/dnsmasq.d that contain any static IP mappings, commented or not.