Pihole on latest update immediately disables blocking

Pi-hole running on Raspbian, everything up to date. Pi-hole v5.4, FTL v5.9.

Expected Behaviour:
Enable blocking in the GUI, expect blocking to stay enabled

Actual Behaviour:
It immediately reverts to disabled. Nothing logged in the pihole logs, pihole continues to respond to DNS queries and DHCP requests, albeit without ad blocking. After running "pihole -g" in shell, it finishes with:

[✗] Pi-hole blocking is disabled

Debug Token:

You could check /etc/pihole/setupVars.conf:
If you should have multiple occurences of BLOCKING_ENABLED, remove all but one of those lines.
Refresh Pi-hole's UI and see if disabling/enabling Pi-hole is working as expected.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.