Pihole not working in network

Please follow the below template, it will help us to help you!

Expected Behaviour:

[I installed Pihole on my brand new raspberry. Added the ipv6 adress shown to my fritzbox as a local DNS, I use ULA as recommend in the forum. Now my traffic should get filtered by Pihole. ]

Actual Behaviour:

[Filtering is perfect on Raspberry or if accesing via OpenVPN. BUT if I activated the DNS in the fritzbox the whole network has no Internet. Only the Raspberry. What do I do wrong? I’m trying for a week now but don’t find a solution
Thanks in advance!]

Debug Token:

[https://tricorder.pi-hole.net/zbuvqsxqk9]

Did you enable Pi-hole to listen to all interfaces ?

Yes I tried this and only listen to eth0. But same procedure on every setting

Well then, on a client, what’s the output of nslookup flurry.com ?

Does it look good on the DNS side of settings on the client ?

DNS request timed out

Yes the DNS Server is added at the client. Tested on Windows and on Android

What about you client network settings/IP parameters/DNS entries? Everything looking good there?

Last time i had the DNS in fritzbox activated the client had the IP from fritz and the right DNS from Pihole. But every Page I tried to visit timed out without the pihole even noticing.
I think something with my Pihole is wrong because if I activate the DHCP-Server and deactivate it in my router my client don’t get any IP.
I reinstalled twice. Sorry I’m a newbie but what I’m making wrong

Than that means that the DNS request was not hitting Pi-hole of it was, it was not answering it.

Enable listen to all, permit all origins (that should make Pi-hole answer to all requests).

When that happens, something else is preventing the DHCP packets to travel properly within the network.

Either they don’t hit the right DHCP server or fritzbox is playing tough to get.

Okay I try it on the weekend and tell what is happening.
I deactivated the DHCP on the fritzbox for ipv6 and ipv4 and restarted both pi and fritzbox as recommend so the fritz should not try to spreed Ips or I’m wrong in this point? do I have to open any port or something like this?

No ports on the router need to be opened for Pi-Hole to work properly.

Even with this setting it brakes down my whole network. I don’t know whats wrong with my network in this point.