Pihole not receiving DNS requests from other devices on network, but appears to be working locally

Please follow the below template, it will help us to help you!

Expected Behaviour:

pihole on raspberrypi should be receiving DNS requests after configuring the router to use the raspberrry pi’s address as its primary DNS server

Actual Behaviour:

No DNS queries are received by pihole

Debug Token:

xpdh1iuhll

I was loathe to post for help as I am sure it is something simple I am overlooking but have been stuck for a week or so now so I’m afraid here I am.
After switching broadband provider I initially had pihole successfully set up, but then something got messed up somewhere, I believe while I was in th eprocess of setting up openvpn, and I cannot get it working again - pihole -r has been tried.

Seems from the debug log that there is a problem with the ip6 resolving, but ip4 looks fine. Some other info below, based on things I’ve seen requested in other related help topics, in case it’s useful.

My router has been configured to use the rpi’s address as the DNS for other devices:

I am able to access the admin panel via 192.168.1.11/admin on other devices, but not pi.hole/admin. In the query logs I see only local requests from the rpi (to a dynamic dns site).

On another local device connected to the router:

$ dig google.com

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-10.P2.fc28 <<>> google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18869
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;google.com.                    IN      A

;; ANSWER SECTION:
google.com.             272     IN      A       216.58.201.14

;; Query time: 23 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Mon May 13 21:25:25 BST 2019
;; MSG SIZE  rcvd: 44

$ dig google.com @192.168.1.11

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-10.P2.fc28 <<>> google.com @192.168.1.11
;; global options: +cmd
;; connection timed out; no servers could be reached

Maybe not related, but I am unable to ssh into rpi from outside LAN even with port forwarding.

Replace 1.1.1.1 DNS2 with the IP of the hole so that you have twice the same IP addres in those fields.
To have your VPN being able to use the Pi-hole disable DNS leakage protection in your VPN settings.

1 Like

Sorry, forgot to say, I’d tried that. Presumably it only uses the second when the first one fails - in any case I have 1.1.1.1 in there otherwise I cannot access the internet (since it has no option but to try the rpi, which just times out).

And I don’t have VPN set up - I got part way and realised pihole was broken.

The DNS is tried and which one is random. It will switch after a number of tries.

Run this command on your pi-hole to if you can reach

dig pi-hole.net @8.8.8.8

1 Like

ah ok, thanks.

And the pi seems to be able to resolve DNS’s fine - just appears to not receive requests from other devices (I am thinking that since when I remove 1.1.1.1 as a backup DNS on my other devices and they then fail to resolve any sites that the router is doing the forwarding correctly, just something on the rpi itself.)

pi@raspberrypi:~ $ dig pi-hole.net @8.8.8.8

; <<>> DiG 9.9.5-9+deb8u17-Raspbian <<>> pi-hole.net @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6287
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;pi-hole.net.                   IN      A

;; ANSWER SECTION:
pi-hole.net.            299     IN      A       206.189.252.21

;; Query time: 42 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Wed May 15 08:37:30 UTC 2019
;; MSG SIZE  rcvd: 56

pi@raspberrypi:~ $ dig pi-hole.net

; <<>> DiG 9.9.5-9+deb8u17-Raspbian <<>> pi-hole.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56925
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1452
;; QUESTION SECTION:
;pi-hole.net.                   IN      A

;; ANSWER SECTION:
pi-hole.net.            300     IN      A       206.189.252.21

;; Query time: 25 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed May 15 08:37:37 UTC 2019
;; MSG SIZE  rcvd: 56

Can you leave secondary DNS blank?

This is kind of a long shot; make sure there isn’t some weird setting that you need to check to share the DNS address via DHCP. It may be under LAN or someplace weird. Consumer routers never cease to amaze.
Try manually refreshing a host too.(it might be working already :slight_smile: )
ipconfig/release
ipconfig/renew

Good Luck

It complains if there isn’t a valid IP in the second DNS box.

However, rummaging around the router pages I found another DNS setting page. This one is locked down (the toggle button doesn’t work and I can’t change the IP addresses here) - from reading around seems this is a widespread problem.

I have a vague recollection that I was able to toggle this off before, so perhaps a firmware update has helpfully broken things… Anyway - it seems like a router problem now rather than pihole (see edit actually), so I’ll pursue with them. Thanks.

edit: So I was able to change this Static DNS page after changing the page shown in my first post to ‘Obtain DNS automatically’. I have tried it on/off and using 192.168.1.11 (rpi’s ip) in the Primary and Secondary DNS boxes.
While playing about with these I lost DNS capability on my laptop at times, but if I ran dig pi-hole.net @1.1.1.1 it always completed. This makes me again suspicious of the rpi/pihole being the culprit, because dig pi-hole.net @192.168.1.11 always times out and is never seen in /var/log/pihole.log.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.