Pihole new install not working

#1

Hello everyone,

very new to the DNS and DHCP server talk. Tbh I have no idea.
Heard about pihole and thought it sounded like a great use for my Pi that was gathering dust.
So i installed pihole on my Raspberry Pi B model and have ran into a few issues, hoping for any advice/help.

Actual Behaviour:

I think i have 2 problems. Firstly the https://pi.hole_IP/admin page cannot be displayed on my network. this made me think i have done something wrong. Secondly I change my DNS settings in my router to go to the address on my Pihole but i can still see adds, so i am assuming something is not correctly setup/installed. I just am not sure what.

status looks good: pihole status
::: DNS service is running
::: Pi-hole blocking is Enabled

instalation log seems ok:

:: Creating log file and changing owner to dnsmasq… already exists!
:::
::: Installing pihole custom index page…
::: Existing index.php detected, not overwriting
::: Existing index.js detected, not overwriting
::: Existing blockingpage.css detected, not overwriting
:::
::: Installing sudoer file… done!
:::
::: Installing latest Cron script… done!
:::
::: Installing latest logrotate script… done!
:::
::: Downloading latest version of FTL…
::: Detected ARM-hf architecture (armv6 or lower)
::: Using ARM binary
::: Installing FTL… transferred… done.
:::
::: Skipping firewall configuration.

I have also already tried a reconfigure but with no changes.
my chosen IP was 192.168.1.81/24
not sure if this is wise IP or not

Debug Token:

token is pwlsswfy2e

Any help is appreciated.

Update on this:

pi@raspberrypi ~ $ sudo service dnsmasq start
[ ok ] Starting DNS forwarder and DHCP server: dnsmasq[…] (already running).
pi@raspberrypi ~ $ sudo netstat -nltup | grep 'Proto|lighttpd|dnsmasq|pihole-FTL’
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 5081/dnsmasq
udp 0 0 0.0.0.0:53 0.0.0.0:* 5081/dnsmasq
pi@raspberrypi ~ $ sudo netstat -nltup | grep ':4711 |:80 |:53 |:67 '
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2318/apache2
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 5081/dnsmasq
udp 0 0 0.0.0.0:53 0.0.0.0:* 5081/dnsmasq

Doesnt look like the lighttpd or FTL software is running. Possible they did not install correctly?

#2

You have Apache running on port 80 TCP conflicting with lighttpd.

sudo systemctl status lighttpd -l

If you have no use for apache:

sudo service apache2 stop
sudo systemctl disable apache2

Start up lighttpd:

sudo service lighttpd start

And check status again:

sudo systemctl status lighttpd -l

For FTL, check status with:

sudo systemctl status pihole-FTL -l

Could try boot here up with:

sudo service pihole-FTL start

And yes, below one will show the ports in use necessary for Pi-hole to run:

sudo netstat -nltup | grep 'Proto\|:4711 \|:80 \|:53 \|:67 '

4711 TCP for FTL;
80 TCP for lighttpd web pages;
53 TCP/UDP for dnsmasq DNS service;
and 67 UDP for dnsmasq DHCP service.

#3

Thanks you for the quick response.

yes that is me sorted. Taking down the appache and a quick pihole -r did the trick now working great.

Next is to decide weather to reset my DNS on each device or disable my DHCP server on BT hub.

It wont let me change DNS on the router not sure what route to take.

Worried having all trafic go to Pihole may actually slow my network rather than speed it up.

Have read a few places that BT Hub can be difficult.

#4