Pihole is blocking whitelisted website

v3-3
#1

I have tried pihole -g, used pihole -w to add the domain, everything, and still the website is blocked. It used to actually say ‘blocked by pihole’ and show the list it was blocked by, but now it just gives me a standard unable to connect message. Thanks!

0 Likes

#2
0 Likes

#3

Hi, I did actually add it using pihole -w domainname. It still wont work. It says “unable to connect” and shows the whitelisted domain as being blacklisted. Occasionally it will show the domain as both blacklisted and whitelisted but some are ipv6 and some are ipv4 and some show cached, etc. I have made sure that ipv6 blocking isnt enabled on the pihole since I dont have it enabled in my router. I’ve tried adding it as ‘name’.com and www.‘name’.com. Nothing. It’s very weird.

0 Likes

#4

OK, are you running into caching issues then?

0 Likes

#5

Honestly, I’m not sure. I tried to flush the dns cache via the cmd function in win10 before. I removed the website from my whitelist and it’s finally giving me the proper pihole blocked message and showing which list it’s in.

So just now, I tried pihole -w blahblah.com, then checked the website and it showed can not connect, then I tried pihole restartdns and got the same thing. This was on my phone via safari. On my laptop, I did ipconfig /flushdns. Got unable to connect using Firefox. Finally, I did pihole -g, and same thing, blocked.

Checked the queries, and it shows two that were forwarded (ipv6), and two that were blocked (ipv4). So at this point I don’t know what to do and I’m confused. Thanks for any help!

0 Likes

#6

Right now, it’s not even in the whitelist. This is what I get when I try to visit the site, along with an unable to connect..

0 Likes

closed #7

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes