PiHole-FTL Crashes on restart. Fixed on reboot

Please follow the below template, it will help us to help you!

Expected Behaviour:

pihole restartdns should restart FTLDNS

Actual Behaviour:

user@pi-hole:~ # pihole status
  [✗] DNS service is NOT running
user@pi-hole:~ # pihole restartdns
  [✓] Starting DNS service
user@pi-hole:~ # pihole status
  [✗] DNS service is NOT running
user@pi-hole:~ #

Debug Token:

Generate Debug fails to create and upload a debug token, until reboot…
This is a post reboot log
Your debug token is: https://tricorder.pi-hole.net/vi2yl1b4hv

I noticed the behavior when trying to install 1) Cloudflared DoH client and then 2) Unbound. Which is when I realized the problem probably existed prior to installing either of these.

How soon after restart are you checking the status? You have so many lists and so many domains that it’s taking 14 seconds for FTL to load.

good point. lemme double check

It’s weird… I did another pihole restartdns and waited like 3 minutes. Same. Pihole-FTL is not running.

It starts in less than 3 minutes after a reboot after the desktop (raspbian) appears. So I stopped it deliberately. Using service pihole stop. Then confirmed DNS service is stopped and tried to restart. Same. This time after waiting 10 minutes. So it looks like manual restarts/starts are failing.

There was a line in the logs that referenced “/” was not found on the line pihole/index.php. It spit that out like three times. I made an edit to the /etc/lighttpd/lighttpd.conf and added a line that had that in it. as requested by [PiPass]. But it didn’t work so I backed out all the changes and removed that line from the conf. So I am not sure why that error is appearing in the logs anymore.

What does sudo systemctl status --full --no-pager pihole-FTL.service say when you do a manual restart? And what does the /var/log/pihole-FTL.log show for the current session?

The lighttpd issue is something unrelated and has to do with Buster.

Let me emphasis that it starts normally on reboot. I am making a change to the upstream DNS server in the settings page of the console and attempting to restart to cement the new settings into place and its failing.

A reboot will start the service even with the new setting [setting to enable Unbound] in effect but Unbound isn’t working so I am making more changes and attempting to restart the service, and it fails again. So this behavior is leading me to believe there is some other underlying problem.

Okay, if you need any further help then providing the status and logs I mentioned will help things along.

● pihole-FTL.service - LSB: pihole-FTL daemon
Loaded: loaded (/etc/init.d/pihole-FTL; generated)
Active: inactive (dead) since Mon 2019-08-12 21:03:43 EDT; 14min ago
Docs: man:systemd-sysv-generator(8)
Process: 377 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)
Process: 1422 ExecStop=/etc/init.d/pihole-FTL stop (code=exited, status=0/SUCCESS)

Aug 12 20:51:44 TNTDNS systemd[1]: Starting LSB: pihole-FTL daemon…
Aug 12 20:51:45 TNTDNS pihole-FTL[377]: Not running
Aug 12 20:51:56 TNTDNS su[1039]: (to pihole) root on none
Aug 12 20:51:57 TNTDNS su[1039]: pam_unix(su:session): session opened for user pihole by (uid=0)
Aug 12 20:51:58 TNTDNS pihole-FTL[377]: FTL started!
Aug 12 20:51:58 TNTDNS systemd[1]: Started LSB: pihole-FTL daemon.
Aug 12 21:03:43 TNTDNS systemd[1]: Stopping LSB: pihole-FTL daemon…
Aug 12 21:03:43 TNTDNS pihole-FTL[1422]: Stopped
Aug 12 21:03:43 TNTDNS systemd[1]: pihole-FTL.service: Succeeded.
Aug 12 21:03:43 TNTDNS systemd[1]: Stopped LSB: pihole-FTL daemon.

It doesn’t like that I did a sudo su, so I didn’t have to type sudo pihole restartdns all the time. Geez!

Try sudo -i instead.

Thanks so much for your help. Can I expect help from this forum for getting PiHole to work with Unbound?

The instructions for setting it up come from the PiHole documentation website. So that’s why I ask

Yeah, it’s a community forum so you should get quite a few people helping with your questions.