Pihole does not seem to be blocking ads after update, so i've downgraded, but still having issues!

Please follow the below template, it will help us to help you!

Expected Behaviour:

has a enable botton, but when click its active for a few seconds

Actual Behaviour:

only is enabled for a few seconds then stops again

Debug Token:

https://tricorder.pi-hole.net/g2nbqews38

updating removes the browser block ext, i.e. the reason i’d like to downgrade, seeing a lot more ads after upgrading then before i upgraded

You are running an open resolver. Turn your Pi-hole off now.

dschaper@Mariner-10:~/shellcheck-stable$ dig pi.hole @xxx.xxx.xxx.xxx

; <<>> DiG 9.11.3-1ubuntu1.11-Ubuntu <<>> pi.hole @xxx.xxx.xxx.xxx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53953
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;pi.hole.                       IN      A

;; ANSWER SECTION:
pi.hole.                2       IN      A       xxx.xxx.xxx.xxx

;; Query time: 73 msec
;; SERVER: xxx.xxx.xxx.xxx#53(xxx.xxx.xxx.xx)
;; WHEN: Mon Feb 24 13:45:34 PST 2020
;; MSG SIZE  rcvd: 52

Edit for Mods: Yes, I am being intentionally blunt.

3 Likes

I don’t follow this. What browser block ext are you referring to?

i’ll work on blocking it with iptables later

Let us know when you do. We won’t be providing any support until that time.

Later means your setup is all the time contributing to DDoS amplification attacks!
Do you have any idea of the security implications opening up your DNS, that you use for bank dealings etc, to the public Internet ?
Its hard to know every aspect in computing but please read up about it a little as these DDoS attacks are a very big nuisance.

EDIT: Consider setting up OpenVPN on server and clients to have Pi-hole everywhere with you:

https://docs.pi-hole.net/guides/vpn/overview/

Thanks.

Before:

pi@noads:~ $ dig +short @xxx.xxx.xxx.xxx txt test.openresolver.com
"open-resolver-detected"

After:

pi@noads:~ $ dig +short @xxx.xxx.xxx.xxx txt test.openresolver.com
;; connection timed out; no servers could be reached

openresolver has been closed

2 Likes

Thank you.

Can you give us an update on what is work or not working and what you would like help with?

the adblocker for chrome and firefox
easylist.txt etc!!!

This is a Pi-hole forum. What Pi-hole issues can we help with?

I updated pihole before i knew about the changes in Remove adblock list style support: https://github.com/pi-hole/pi-hole/pull/2912

so i’m trying to downgrade so i could still use the adblock list style, because i’m seeing more ads since upgrading then before

The adblock style lists never worked. We removed the support for them since the actually broke things.

If you still really insist on needing to use the adblock style lists, then you can find versions of those lists that have been pre-parsed for DNS adblockers here:

[root@shawn-route ~]# pihole checkout master
  Please note that changing branches severely alters your Pi-hole subsystems
  Features that work on the master branch, may not on a development branch
  This feature is NOT supported unless a Pi-hole developer explicitly asks!
  Have you read and understood this? [y/N] y

  [i] Shortcut "master" detected - checking out master branches...
  [i] Pi-hole core
  [✓] Switching to branch: 'master' from 'refs/heads/master'
  [i] Already up-to-date.
  [i] Web interface
  [✓] Switching to branch: 'master' from 'refs/heads/master'
  [i] Already up-to-date.
  [✓] Detected x86_64 architecture
pihole-FTL-linux-x86_64
  [i] Running installer to upgrade your installation

  [✓] Root user check

        .;;,.
        .ccccc:,.
         :cccclll:.      ..,,
          :ccccclll.   ;ooodc
           'ccll:;ll .oooodc
             .;cll.;;looo:.
                 .. ','.
                .',,,,,,'.
              .',,,,,,,,,,.
            .',,,,,,,,,,,,....
          ....''',,,,,,,'.......
        .........  ....  .........
        ..........      ..........
        ..........      ..........
        .........  ....  .........
          ........,,,,,,,'......
            ....',,,,,,,,,,,,.
               .',,,,,,,,,'.
                .',,,,,,'.
                  ..'''.

  [i] Enabling EPEL package repository (https://fedoraproject.org/wiki/EPEL)
   Error: Unable to complete update, please contact support

curl -sSL https://install.pi-hole.net | bash

https://tricorder.pi-hole.net/5662s3yttd

tried curl -sSL https://install.pi-hole.net | bash

still receive [i] Enabling EPEL package repository (https://fedoraproject.org/wiki/EPEL)
Error: Unable to complete update, please contact support

Try the instructions for Cent7 at https://fedoraproject.org/wiki/EPEL