Pihole does not process DNS queries for clients

Expected Behaviour:

-I would like pihole 'doing the job', meaning procesing DNS queries from all the clients in my LAN, and blocking addvertising domains
-OS : Ubuntu 20.04
-hardware : Intel NUC 5pphy
-Internet provider : Free (France) + DNS server is set to Pihole static ip adress (192.168.1.17)
-Pihole DHCP disabled. Box

Actual Behaviour:

10 clients are connected to the internet box. Pihole does not process the DNS queries from these clients. Pihole admin page show no blocked domain / no activity (except 1 ou 2 queries from pihole device). The pihole DNS server is not responding.

Debug Token:

h7jpje5gb4

What I have already checked:

  1. From pihole device :

$ dig www.google.com @ 192.168.1.17
; <<>> DiG 9.16.1-Ubuntu <<>> www.google.com @ 192.168.1.17
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26183
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.google.com. IN A

;; ANSWER SECTION:
www.google.com. 259 IN A 142.250.74.228

;; Query time: 8 msec
;; SERVER: 192.168.1.17#53(192.168.1.17)
;; WHEN: lun. juil. 19 23:47:13 CEST 2021
;; MSG SIZE rcvd: 59

  1. From other client: pihole is not responding

$ dig www.google.com @ 192.168.1.17
; <<>> DiG 9.11.5-P4-5.1+deb10u5-Debian <<>> www.google.com @ 192.168.1.17
;; global options: +cmd
;; connection timed out; no servers could be reached

  1. Port 53

$ sudo netstat -plnt
Proto Recv-Q Send-Q Adresse locale Adresse distante Etat PID/Program name
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 134394/pihole-FTL
tcp6 0 0 :::53 :::* LISTEN 134394/pihole-FTL

(Use the </> - Preformatted text menu option for your command output. That way, you would have been able to post @192.168.1.17 without the extra space that was probably introduced by you just to appease Discourse's editor. :wink: ).

Please verify that your firewall would allow access to Pi-hole's ports as required.