Pihole Docker 0 Blocked

I setup pihole on QNAP container station with the defauly pihole docker image and it seems to be blocking nothing. (that’s was the admin interface says) Total queries 0. Queries Blocked 0. Percent Blocked 0.0 %. Domains on Blocked list 0.

I believe its because i setup the server address on my machine incorrectly… but i am not sure what is wrong with the the way i did things…

So what i did after setting up the container i simply copied the ip address that my pihole setup was running on and added this address as my DNS server address under windows TCP/IP adapter settings…

Most of the tutorials i see seem to suggest you either switch your router to use the pihole as your DNS resolver or to use pihole to as a DHCP server… neither of these options are practical for me since i have other people on my home WiFi that dont want to use pihole…

I was assuming that i could simply set the address of the pihole as my DNS server address in windows? Is this possible without using DHCP or changing the DNS addresses on my router? If so then was is invalid about manually chanigng my DNS serveres in windows?

(Update) Edit:
I did notice that when i do ipconfig /all i do see that there are a number of ipv6 DNS address i am getting from my DHCP settup alond with the address of my pihole

DNS Servers . . . . . . . . . . . : 2620:119:35::35
2620:119:53::53
fe80::a264:8fff:fee1:b8e6%11
192.168.1.81

So i assuming the reason its not working is because the ipv6 DNS servers are doing all the resolving before it gets to my pihole…

I attempted to completely turn ipv6 of, but that bricked my connection…

So my question is this what am i suppose to do in this case when i am getting ipv6 DNS address from my ip? I am i suppose to turn on ipv6 address on the iphole then assign this address as my staic DNS servers for ipv6?

If it’s killing the connection with v6 off you have connectivity issue(s).

Could be misconfiguration or in inadequate hardware (modem/router).

Edit okay you can load admin.

From the windows machine can you ping pihole with the assigned ip? Does the admin page load?

From terminal on the pi run

pihole -d

Post token or output here

Oh this is a docker install.

Note to self don’t forum before coffee!

The admin page loads and i can log into it and view stats…in order to try to execute that command i tried to SSH into it using pi@xxx.xxx.xxx.xxx and it wasn’t accepting my password… although i can log into the web admin interface… wouldn’t the password for the ssh connection be the same as the one for the webadmin interface??

I was able to get a console for the container using a garbage webconsole that came the the garbage qnap NAS i am running this on… and i ran “pihole -d” and something curioss happens when i do that.

What happens is that the statics in the admin page indicate that there were 2 queries and 2 blocked queries. Unfortunately i cannot paste the output of that command since the garbage webconsole on my garbage QNAP nas is not allowing me to copy paste its text correctly…

So it seems to me that my pihole is in fact working, but my settings on my PC are not sufficient…

So it seems to me that the point of confusion is how does pihole interact/use ipv6?

If my isp router is giving me dynamic address with ipvs6 address and i cannot simply turnoff ipv6 and then i am i suppose to somehow replace the isp ipv6 DNS with address that refer to the pihole??

I am i even on the right track with this? How do other people handle such a situation?

Seems to me that you might be able to overcome this ipv6 problem with pihole for the dhcp server.

yea… i am sure i will be able to figure it out… i figure i wasn’t the first person to hit this issue so i figured there would be a known way of dealing with this…