Pihole DNS Stopped working

Hey All,

I’ve been lurking here for a long time but haven’t had any major issues until now.

I’ve installed Unbound 1.9.5 from source, as the latest version via package manager is 1.9.0 and since I have a Pivpn client running, I wanted to have the latest and greatest.

All good until this, as right now, even if my dns is set to cloudflare(instead of 127.0.0.1#5353) my devices have no internet( unless I manually choose a DNS server on the devices)
I tried to reconfigure it, disable unbound, restart, I’ve checked my router( no changes there, still OpenWRT)

The Pi itself can update, even though it connects via wlan0, and DHCP server advertised on the router is the Pi.( Same goes for the router, it can pull opkg updates)
I can connect and browse without issues on OpenVPN( even with Unbound running, and the DNS has been set up to be recursive) yet on local net I have no DNS working.

Any advice would be greatly appreciated :slight_smile:

Debug Token:

[https://tricorder.pi-hole.net/y68wlkuvaf]

Edit: Resolv.conf:

pi@raspberrypi:/etc $ cat resolv.conf

Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

DO NOT EDIT THIS FILE BY HAND – YOUR CHANGES WILL BE OVERWRITTEN

nameserver 127.0.0.1

There appears to be a connectivity problem with the Pi on the network. From your debug log when Pi-Hole was testing itself:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] www.ero-tv.pl is 0.0.0.0 via localhost (127.0.0.1)
[✗] Failed to resolve www.ero-tv.pl via Pi-hole (192.168.8.205)
[✓] doubleclick.com is 172.217.16.110 via a remote, public DNS server (8.8.8.8)
1 Like

Hey, yes, thank you, I just saw it also after reinstalling the whole thing( with old Unbound via package manager) and it’s still not working…
Any idea why could that be?
DHCP is set as 6,192.168.x.x (IP of the Pi) and DNS also set as the same IP (without the 6,) on my Openwrt router.
Maybe it’s double NAT?
I can’t get it to work even with Cloudflare DNS set-up in Pihole… I must’ve messed something up, or something broke on the router while there were no DHCP/DNS available throughout a few hours…I’m kindla clueless. Must be missing a setting somewhere.

So I tried to install the Docker image… lo and behold it worked.
Went back to normal Pihole version ( non docker) not working once again…

I haven’t changed a thing on the router but I’m really getting totally clueless.