Pihole cannot resolve hosts

Please follow the below template, it will help us to help you!

Expected Behaviour:

  • Admin UI should work.
  • Should be able to upload debug logs
  • Dnsmasq should be present and running
  • Should be able to ping google.com from the command line in a ssh session.
  • Should be able to run upgrades

Actual Behaviour:

The admin UI is not running on http://{ip}/admin. An nmap scan seems to suggest ports 80 and 443 are not open on the pihole.

If I run sudo service dnsmasq status (a request I have seen in other help requests) I get back

● dnsmasq.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

I have tried running pihole -r but it fails at

  [i] Checking for existing FTL binary...
  [✗] Downloading and Installing FTL
  Error: Unable to get latest release location from GitHub
  [✗] FTL Engine not installed

I have attempted to run pihole -d -a but it always fails to upload the log. See below in Debug Token section for manually updated logs.

Pinging various hostnames fail. However the pihole does apparently have net access as it can successfully ping

Debug Token:

debug logs fail to upload, but have uploaded to pastern here: pihole_debug-sanitised_201902271628 - Pastebin.com

I have self-resolved:

Firstly I ran the suggested edit from Problem with FTL and dnsmasq after pihole -up (Ubuntu 16.04.5 LTS) - #9 by DL6ER

And then I ran the chown updates described in Pi-hole no web interface access and lighttpd.service failed to start - #34 by dieterg which allowed me to restart lighttpd.

As you have likely discovered, starting at Pi-Hole V4.0, dnsmasq no longer runs as a separate process. The dnsmasq code is embedded in pihole-FTL and pihole-FTL runs in place of dnsmasq.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.