Pi-hole won't install/work on ubuntu 18.04

Please follow the below template, it will help us to help you!

Expected Behaviour:

the system should install using ubuntu 18.04

Actual Behaviour:

it hangs and the webinterface states "lost connection to api"

Debug Token:


Please run the following command:

sudo service pihole-FTL restart

Then post the output of these commands:

sudo netstat -nltup | grep 'Proto\|:53 \|:5053 \|:5353 \|:5335 \|:8953 \|:67 \|:80 \|:471'

sudo service pihole-FTL status

(That screenshot is hard to read. It would be preferred if you would paste the text output and format it via the </> Preformatted text menu option as required. Makes it more readable, and also easier for other users to copy and paste relevant parts for reuse.)

It would seem you are trying to have Pi-hole listening on an inexistent interface:

unknown interface he-ipv6

As a result, Pi-hole won't bind any ports.

See if you can run

pihole -r

and select Reconfigure.

I have tried to run pihole -r more then once selecting both reconfigure and repair. I have also tried to reinstall on the same VM to no avail. Later today i will be installing it on an LXC. In hopes i can get a working version there. Ill update you on what im able to get using the LXC.

Update after a fresh install (the installer only gave 2 sources for adlists?) I seem to be on a login loop where i have to check remember me to login. If i dont it will kick me back to the main screen. Going to almost any page gives me this popup... DataTables warning: table id=groupsTable - Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1
Let me know if you want a video of what is happening. However i think your one line install is broken. I have tried it on a few VM's and LXC's to get the same issue.

That's expected. Current versions of pihole include only 2 default lists. Other lists were deprecated and/or no longer maintained.

Please generate a debug log, upload it when prompted and post the token here.

Here you go fresh install debug link: https://tricorder.pi-hole.net/wgrvy6z31b

Any ideas I keep reinstalling to a fresh lxc to nothing changing. I cant seem to get it working ever.

I have Pi-hole running on a Ubuntu 18.04 server (no VM). I had zero issues installing Pi-hole. It work without a single problem.

Have you already fixed this? Which interfaces do you have on your machine (try ip address to see them).

i have fixed that via a complete reinstall. i will however attempt with a ubuntu 18.04 lxc to see if that works. so far i have been trying 20.04 as it claimed to be supported.

Sorry I'm not familiar with LXC. Is this like Docker? Or is it more similar to VirtualBox where you really have an independent operating system? Does your working 20.04 setup also run in LXC?

yes it runs in an lxc and the whole idea for a lxc is to have fast bootup times (like 3 sec.) it can be thought of like a virtual machine. also my 20.04 does not work and it is in an lxc. However i have tried a virtual machine to no help. i have also tried a normal system with no virtual aspect running 20.04 and that doesnt work either.

What kind of hardware did you try it on? The vast majority of Pi-hole is natively installed and I can guarantee for dozens if not hundreds if not thousands of properly working Pi-hole installations on 20.04 natively. I cannot speak for LXC here.

it was just a Toshiba laptop that i have since gotten rid of.

also lxc can be compared to dockers since they both run os-level virtualization.

Even when I don't understand Docker very well, I see that there are many implications when it comes to Docker. Which is also the reason for Pi-hole offering a non-trivial container.

true i just cant seem to figure out whats wrong since im using the one line install. im going to try later tonight for a older version and see if that helps. if it does ill have to open a ticket on github or something.

Maybe you can copy the entire output of the installation. An experienced developer may spot an abnormality.