Pi-Hole Win10 DNS

Newbie here so be kind.
I have only just enough knowledge to be dangerous to myself and my network.
I have just started with Pi-hole (5) running on a Raspberry 4.
I added Ubound and it "seemed to work"
Previously I was using NextDNS but decided I want to be fully in charge. My network is about 10 or so devices, 2 of which run Win10.
With NextDNS it was necessary to initially add the DNS servers manually in the Network Card in each Win10 machine for IPV6I
I believe I shouldn't need to to that now but I do for the IPV6 and I don't quite understand why.
If I set the DNS server to auto, Ipconfig reveals I do get the IPV6 address of my Pi-hole but I also get the Link Local Address (fe80::...... )listed as the DNS as well.
I obviously still still getting the IPV6 DNS but not from the Pi-hole, so i don't get blocking..
I have my gateway (Modem) DNS set to the Pi-hole IP but I am only able to set the IPV4 DNS in it.
I assume Windows has a "fallback" DNS for IPV6.
I do have root access to my modem, so I guess I could do something there.
Has anyone struck this and is there some work around to get the either the link local address removed from the DNS list or the DNS of the link local address (in windows?) set to the Pi-hole?

After a bit more thought, this is not the problem.

Because Pi-hole is a "DNS" (well its a cache) it is assigned as the DNS. But Ubound is also the upstream DNS and is also assigned as a backup DNS but for IPV6 only not the IPV4.
For some reason Windows 10 seems to be using the Ubound as the primary IPV6 DNS and Pi-hole as the secondary.

Ok I fixed this by fiddling.
Unfortunately I can't say what was actually wrong!
Basically I started by stopping and restarting pi-hole. No change
Next I stopped & restarted Ubound. This was interesting because I had trouble getting it to restart. But restart it did. Need to investigate that.
No change.
I flushed the logs, then restarted Pi-hole. No change. Flushed the network table and restarted the DNS resolver.
That did the trick.
Each time I disabled & enabled the network card to force a new DHCP.
Now I have an IPV4 DNS address along with the IPV6 version of the IPV4 as well as the IPV6 DNS and the local address of the Ubound.
I went to the other Win10 machine and ran ipconfig and the DNS listing was the same but the IPV6 was still bypassing the Pi-hole
A reboot fixed it all.
I hate it when a reboot fixes something that doesn't appear to be broken.
Guess I have got some reading to do to find out why it now works.

Obviously I am missing something that Microsoft does in this area.

OK...so it was not fixed and I can't for the life of me understand why. And I can't really say what breaks it.
But it is REALLY strange.

I have a laptop sitting along side with the same adapter settings. It is OK, Pi-hole does its thing and blocks the adds.

And here is the really weird part. If I log on as usual to windows (I have a User account with admin privileges) pi-hole does not block anything.

If I log off windows and log on again as admin then pi-hole blocks adds etc.

Its the same machine with the same adapter settings.

IPconfig /all
DNS Servers . . . . . . . . . . . : 2001:8003:6d47:b500:c77e:cce3:be0b:8fd5
This is the same as the machine alongside it that works.
Perhaps its a Firefox problem but I am not sure how that could be, I haven't modified Firefox other than the normal configuration.

I am about out of ideas of where to look

Well I found it. And it might also answer a few other problems people are having after first installing pi-hole.

I was using another program to do some hardware stuff and had to set the IP address of the network card manually.
When I reset the card to auto and went back to normal, Pi-hole DHCP allocated the same IP it was originally running with and update the DNS servers to point to Pi-hole.

BUT it did not update the gateway. A disable, enable of the network card didn't fix it. Neither did a reboot. I had to reset the network so i got a full DHCP which updated the gateway.

For someone using their modem as DHCP and changing addresses when changing to Pi-hole may well end up with the gateway set wrong. Everything still works except its not using Pi-hole even though it DHCP has provided the Pi-hole address, it wont get there unless the gateway is able to point to it.
Windows 10 appears to have a "default last resort" DNS address though I don't quite understand how it can get past a wrong gateway address. Perhaps its a windows cache thing.

Just adding here for information.

After a windows update, my PC was no longer using my Pi-Hole for DNS (so no blocking)
I had to manually set the IP address and gateway, disable & enable the network card, wait a few minutes check I was now getting blocking and return the settings to auto.
Then it worked as it should.
It seems the DHCP of Pi-Hole is not setting the gateway when it does a DHCP renew.

Further it seems windows upgrade uses its own internal preset DNS because you cannot block windows upgrade via the Pi-Hole.