Pi-Hole Update wird nicht installiert

Gerade habe ich das System meines Raspberry Pi auf den neuesten Stand gebracht. Zuerst per sudo apt update, daraufhin wurde eine neues Paket angezeigt, welches ich per sudo apt full-upgrade installiert habe. Danach habe ich einen Neustart durchgeführt und wollte noch das Pi-Hole aktualisieren.

Hierfür habe ich nach dem Neustart den Befehl pihole -up eingegeben. Laut danach erscheinender Anzeige stand ein FTL-Update bereit und die Installation wurde automatisch durchgeführt.

Als ich zur Kontrolle danach nochmals pihole -up eingegeben habe, ging das gleiche Spiel wieder von vorne los. FTL nicht aktuell, Installation wird durchgeführt, usw.

Nach dem dritten Mal haben ich es gelassen und nicht noch einmal probiert.

Im Web-Interface von Pihole wird allerdings auch kein verfügbares Update angezeigt. Installiert ist (und war bereits vor dem Start des Updates heute) FTL v.5.3.4. Es scheint sich trotz dreimaliger Installation also nichts verändert zu haben.

Abgesehen von dem Pi-Hole ist nur Unbound und eine Firewall auf dem Pi installiert. Das System ist Raspberry OS Lite.

Kann jemand dieses merkwürdige Verhalten erklären?

Please upload a debug log and post just the token generated by

pihole -d

allowing to upload when prompted, or do it through the Web interface:

Tools > Generate Debug Log

I can confirm this behaviour. I run pihole -up and an FTL update is detected (although the pi is already running 5.3.4) and installed. If I re-rerun pihole -up the FTL update is detected again.

Your debug token is: https://tricorder.pi-hole.net/qeo4kam5uc

Thanks for the immediate reply!

My token is: https://tricorder.pi-hole.net/qfyt8wqexa

You are on the latest Pi-hole version.

*** [ DIAGNOSING ]: Core version
[i] Core: v5.2.2 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
[i] Remotes: origin	https://github.com/pi-hole/pi-hole.git (fetch)
             origin	https://github.com/pi-hole/pi-hole.git (push)
[i] Branch: master
[i] Commit: v5.2.2-0-g41bdb74

*** [ DIAGNOSING ]: Web version
[i] Web: v5.2.2 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
[i] Remotes: origin	https://github.com/pi-hole/AdminLTE.git (fetch)
             origin	https://github.com/pi-hole/AdminLTE.git (push)
[i] Branch: master
[i] Commit: v5.2.2-0-g780dff0

*** [ DIAGNOSING ]: FTL version
[✓] FTL: v5.3.4

I do know that.

But if I run pihole -up it still reports a new version is available and installs it (or re-installs 5.3.4).

I just verified this. Right now the pi is updating again.

Same here.

However, good to know that I'm running the latest version of Pi-Hole. Thanks for checking!

If you are on the latest version, stop running pihole -up.

usually it reports "no update available" then and quits.
That's why we are reporting this issue.

Something has changed on the github HTML page source such that:

curl -sI https://github.com/pi-hole/FTL/releases/latest | grep --color=never -i Location | awk -F / '{print $NF}' | tr -d '[:cntrl:]'

now returns: v5.3.4socket-worker-5029ae85.js

There is another line that matches the grep -i Location.

Grepping for 'Location:' would seem to fix it.


Don't run pihole -up in a script or cronjob.

Who says i do so?

Just a reminder.

Is there a reason for this recommendation? I am having the same issue (FTL keeps updating to the same version). This was never an issue until recently. Something changed?

GitHubs API hat sich geändert, siehe Pi-Hole Update wird nicht installiert - #11 by DanSchaper.

Does it mean that I have to adjust any settings?

The link was to the pull request that will change the Pi-hole code to resolve this problem. You don't have to do anything other than ignoring the update notification.



The recommendation of "Don't run pihole up on a cron job or scrip"? We've always said that. It's not a smart thing to do and the first time you update to a non-backwards compatible update or major version change then you'll understand why. Seems like it doesn't matter what we say, people do it anyways and it will cause you all kinds of problems. The only way to learn the lesson is to have it happen to you, I guess.