Pi-Hole und FritzBox Setup Anleitung

fritzbox

#42

Das kann nicht sein, wenn diese Gerät von der FritzBox seine IP bekommt muss das gehen.
Mach mal nen ipconfig /all und schaue ob dort alles stimmt.
Auf der FritzBox unter Netzwerk steht diese Gerät mit seiner v4 Adresse?


#43

Also unter netzwerk / fritzbox besitzt das Gerät nur IPv4 und keine IPv6. Unter ipconfig /all sieht alles gut aus


#44

evtl. statische IP und in der FritzBox Haken bei ‘immer selbe Adresse zuweisen’ nicht gesetzt?
Um welchen Typ von Gerät handelt es sich denn?


#45

Also meine Konstellation sieht wie folgt aus Fritzbox,Raspberry 1mit Kodi Osmc und Raspberry 2 (Pi hole) mit raspbian Jesse und sonst PC Windows …

Alle Geräte haben bei mir feste IP Adresse d.h. Häkchen via Fritzbox gesetzt


#46

Feste IP ist das nicht, das bedeutet nur, dass fritzbox immer die gleiche IP zuteilt.
Welches Gerät genau bekommt keine v6 Adresse?


#47

Hallo zusammen, klasse Anleitung und tolle Tipps. Ich habe zwei Frage und hoffe, das jemand helfen kann :slight_smile: Ich habe meinen pi-hole am Laufen. Ad Blocking funktioniert und schnell ist auch alles.

  1. Wie muss meine Konfig aussehen, falls ich bei einem Pi.hole Ausfall weiterhin ohne Ad-Blocker dann über meine FB DNS Auflösungen bekommen möchte?

  2. Kann ich einen Host komplett vom Ad-Blocking raus nehmen?

Vielen lieben Dank im Voraus


#48

Na ja eigentlich ist das ein Raspberry mit OSMC aber das tut glaube ich nichts zur Sache weil die DNS Auflösung müsste ja für IPv4 sowie IPv6 funktionieren.

IPv6 DNS Auflösung funktioniert ja wunderbar nur die DNS Auflösung bei IPv4 nicht…

Grüße und guten Start in die neue Woche


#49

Dann mach doch mal ein ifconfig auf OSMC und schau was die Kiste an Adressen hat.
Wenn du die Adresse des DNS Servers geändert hast musst du den OSMC auch neu starten. Denn falls dieser eine dynamische ip hat, zeigt dessen DNS Abfrage immer noch zu deine FritzBox. Kannst du dir mit: cat /etc/resolv.conf anschauen wie dort der DNS Server gesetzt ist.


#50

Hallo,
ich habe den Anleitungen hier gefolgt und bekomme das Pi-Hole nicht zum laufen d.h. Werbung wird weiterhin angezeigt. Meine Konfiguration:

FRITZ!Box 5490
PIv6 deaktiviert
Home Network -> Home Network Overview -> Details for Pi-Hole -> Always assign this network device the same IPv4 address


Home Network -> Home Network Overview -> Network Settings -> IPv4 Adresses -> Local DNS server: Pi-hole IP

Pi-hole auf Raspberry Pi 3 mit Stretch
Settings -> DNS -> FB-IP als Custom 1 eingegeben, alle anderen deaktiviert
2018-07-10%2010_41_24-Pi-hole%20Admin%20Console
Advanced DNS settings -> alles deaktiviert
2018-07-10%2010_41_50-Pi-hole%20Admin%20Console

Würde mich sehr über Hilfe freuen.


#51

Im Pi-Hole sollte die IP der FB im DNS-Bereich raus, dafür mehrere DNS (z.B. Google, OpenDNS, usw.) einschalten.

Durch die FB bekommen alle Geräte per DHCP eine IP und als DNS die IP vom Pi-Hole mitgeteilt. DNS-Anfragen gehen ans Pi-Hole, werden gefiltert und an die jeweils angekreuzten DNS-Server weitergeleitet.

Bei den Endgeräten würde ich den verwendeten DNS prüfen (z.B. bei Android mit der App Aida64).


#52

Oder aber so lassen und dies machen (so funktioniert auch das Auflösen der lokalen Adressen):


#53

EDIT: Problem gelöst. Der Fehler lag darin, dass ich in der Konfiguration des Pi-Hole den falschen Netzwerkadapter (LAN statt WLAN) gewählt habe.

Viele Dank für eure Antworten. Ich habe beides probiert und nach einem DNS Flush und Reboot meines Rechners konnte mein Browser keine url’s mehr auflösen. Eine Idee, was ich falsch mache?

Szenario 1

Szenario 2



#54

Hallo zusammen,

vielen Dank für die zahlreichen Tips.

Ich habe mal versucht, das alles (graphisch) zusammenzufassen.

Wie unten dargestell, läuft bei mir dieses Szenario zuverlässig. Ob tatsächlich alles richtig eingestellt ist, weiss ich jedoch noch nicht. Verbesserungsvorschläge sind herzlich willkommen.

Grüße
Hausmeister

pihole-Konfiguration_Fritzbox.pdf.zip (603.1 KB)


#55

Ich habe spaßeshalber mal Deine Konfiguration umgesetzt. Allerdings werden bei mir im Dashbord und in Query Log nur IPs und keine DNS-Namen angezeigt.

Follow up:
Nun habe ich es zum Laufen gebracht. Ich habe dezidiert die Fritzbox als Router angegeben:


#56

Danke für die Rückmeldung.

Wo kann ich die Fritzbox als Router angeben? Finde diesen Eintrag bei mir nicht :thinking:

Grüße
Hausmeister


#57

das geht nur in der aktuellen Beta-Version.
Settimgs–>DNS–>Use Conditional Forwarding


#58

Super. Danke Dir.

Grüße
Hausmeister


#59

wie läuft die Beta? Wenn sie Stabil läuft würde ich das auch gerne ausprobieren. :slight_smile:


#60

Die beta läuft ohne Probleme.


#61

Wie installiert man die Beta-Version?

Grüße
Hausmeister