Pi-Hole+Unbound Fix

I just wanted to leave this here in case anyone runs into the same or similar issue.

I just installed and updated Pi-Hole.
(At the time of writing this, versions were Pi-Hole V5.11.4, FTL V5.16.1, Web Interface V5.13)

Followed the online instructions to install Unbound.

The problem starts here. Unbound not allowing mobile device to connect to the internet.

I ran

dig pi-hole.net @127.0.0.1 -p 5335

got back

; <<>> DiG 9.16.27-Raspbian <<>> pi-hole.net @127.0.0.1 -p 5335
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 21576
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;pi-hole.net.			IN	A

;; Query time: 10 msec
;; SERVER: 127.0.0.1#5335(127.0.0.1)
;; WHEN: Sun Jul 31 22:54:54 BST 2022
;; MSG SIZE  rcvd: 40

Then I ran the following to check what was running on port the Pi-Hole ports.

sudo netstat -nltup | grep 'Proto\|:53 \|:5053 \|:5353 \|:5335 \|:8953 \|:67 \|:80 \|:471'

Got back

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 127.0.0.1:4711          0.0.0.0:*               LISTEN      1467/pihole-FTL     
tcp        0      0 127.0.0.1:5335          0.0.0.0:*               LISTEN      1505/unbound        
tcp        0      0 127.0.0.1:8953          0.0.0.0:*               LISTEN      1505/unbound        
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN      1467/pihole-FTL     
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      564/lighttpd        
tcp6       0      0 :::53                   :::*                    LISTEN      1467/pihole-FTL     
tcp6       0      0 ::1:4711                :::*                    LISTEN      1467/pihole-FTL     
tcp6       0      0 :::80                   :::*                    LISTEN      564/lighttpd        
udp        0      0 0.0.0.0:53              0.0.0.0:*                           1467/pihole-FTL     
udp        0      0 0.0.0.0:67              0.0.0.0:*                           1467/pihole-FTL     
udp        0      0 127.0.0.1:5335          0.0.0.0:*                           1505/unbound        
udp        0      0 0.0.0.0:5335            0.0.0.0:*                           246/avahi-daemon: r 
udp6       0      0 :::53                   :::*                                1467/pihole-FTL     
udp6       0      0 :::5335                 :::*                                246/avahi-daemon: r 

As you can see, the avahi-deamon was running on #5335 as well. The fix for this was simple. I just changed the listen port to #5334 under Settings > Upstream DNS Servers to #5334.

Then I ran

sudo service unbound restart

After that the wifi on my mobile devices locked in right away.

Hope someone finds this useful. Be well.

Unbound is not running on that port - it is on port 5335.

My apologies. That was a typo. I'll correct it now