Pi Hole stops working


#5

What instructions are you following ?
Do you have a link ?


#6

The ones you linked.

  1. Run the Curl script
  2. Follow the install prompts
  3. Log into NetGear router
  4. Update the DNS fields from “Get Automatically from ISP” to “Use These DNS Servers” with 10.0.0.8 as Primary, and 8.8.8.8 as Secondary.


#7

Aha, this bit:

::: Installation Complete! Configure your devices to use the Pi-hole as their DNS server using:

It means go finish setting your router according to the Installation instructions on the main page:

Dont skip the manual :wink:


#8

Dont need to do that.
read the instructions on the main page!


#9

Apparently I’m missing something that I’m not understanding what you’re pointing at. Which step specifically?

I took the numbers provided in the setup of Pi Hole and plugged them into my router, just like the instructions said. What am I missing here?


#10

Scroll down on the main page until it reads “1. INSTALL A SUPPORTED OPERATING SYSTEM”:

Step 3.


#11

Right. Which I did. Raspbian Jessie is supported: Hardware/Software Requirements


#12

Sorry, i missed out on one Picture.
Let me have look again.


#13

Ok, did the instructions tell you to change the “Domain Name Server (DNS) Address” for the “Internet Setup” section ?

I cant see it in the second picture but you need to find if your router’s DHCP service can, besides handing out IP addresses to clients, also can give the clients a DNS server address, namely that of Pi-Hole.
If not possible with your router, disable the DHCP service entirely “Use Router as DHCP Server” and activate the DHCP service on Pi-Hole as a substitute (in the Settings section on the web GUI).


#14

The Internet Setup area was the only location within the router to set DNS. The area where DHCP is set only has the options shown of start/end IPs, nothing else. What you see on that screenshot is what you get.

Before I undo all these changes and make additional, I just want to bounce my steps off you for review:

  1. Revert changes on MI424WR for both the bridge and ethernet/coax levels
  2. Set DNS on the NetGear back to “Get Automatically from ISP”
  3. Uncheck the “Use Router as DHCP Server” on the NetGear
  4. Go into the Setting section of the Pi Hole UI

(and this is where I need help)

  • Check “DHCP Server Enabled”
  • Do I do anything to the range of IPs to handout, or leave as “10.0.0.201 - 10.0.0.251”?
  • Do I want to check “Enable IPV6 Support”?
  • Under Advanced DHCP Settings, should I keep the Domain set as “local”?
  • Under Advanced DHCP Settings, should I keep the Lease Time as “24”?
  • Do I need to make any changes under the DHCP Leases section?

#15

These steps are correct.
Dont know bout first one as I dont know how your network is setup.

Do 10.0.0.10 - 10.0.0.254.
That leaves 9 addresses (minus the IP of your router) available to be configured with static IP addresses.
I would configure Pi-Hole to be IP 10.0.0.2.

Why not. --> Not at first.

Why not give it your own FQDN like for example “thisismyusername.uk

Yes.

Nope.
These will be populated when the clients start using your new DHCP service.


#16

I’ll give that a shot and follow-up shortly. Appreciate you taking your time to assist. 10.0.0.2 is taken unfortunately. I’m all booked up from 10.0.0.1 - 10.0.0.12 due to having a smart home (garage door, nest, ecobee, tv, august door lock, etc.)


#17

Just realized, at first try without IPv6 support!
Can switch later if necessary.


#18

Only put devices on static if absolutely necessary/vital for the functioning of your network or very important services (garage door).
The other devices can be assigned a static lease using Pi-Hole’s DHCP service via the “Static DHCP leases configuration” section using their unique MAC address.


#19

All the above changes made, but unfortunately its not blocking anything.


#20

Looks like it isn’t blocking anything on my 5G channel, but my 2.4G channel devices are blocking ads. Strange.


#21

Clients will need to renew their IP address/lease first to receive the new DNS server (PI-Hole) as a resolver.
This can be done by bringing down the network interface and up again,
or disconnecting the wire,
or rebooting.

Below link is a good test for the devices:

http://pi.hole/admin/

If it doesnt show the admin page, its not using Pi-Hole to resolve names to IP addresses.

It might be that your router deals out different IP details to the two channels.
Most PC’s and Pads will show you their network details via some tool or in the settings.
Even a windows PC will show you from who it received the IP details via DHCP:

C:\> ipconfig /all
Windows IP Configuration
   DHCP Enabled. . . . . . . . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 10.0.0.11(Preferred)
   Lease Obtained. . . . . . . . . . : vrijdag 5 mei 2017 0:20:56
   Lease Expires . . . . . . . . . . : zaterdag 6 mei 2017 0:20:55
   DHCP Server . . . . . . . . . . . : 10.0.0.8
   DNS Servers . . . . . . . . . . . : 10.0.0.8

#22

Some routers don’t let you set the DNS server via DHCP, but we do have a generic FAQ that may help:

Also, you can disable your router’s DHCP server and use Pi-hole’s built in one if all else fails.


#23

Ohw man your so too late :wink:


#24

Alrighty…back with a fresh cup of coffee!

Unfortunately ad blocking is still pretty spotty. Works on my wife and my iPhones if we are on the 2.4G channel, not the 5G channel. I have my laptop hooked up to my 2.4G channel as well as the 5G channel and it isn’t blocking anything on either. I unplugged the Pi Hole ethernet cord and plugged it back in, as well as reset my laptop and ran ipconfig /release and ipconfig /renew but neither solved this problem.

What next?