Pi Hole, Speedport, IPV6 - ich weiß nicht weiter

#1

Hallo liebe Community, dies ist mein erster Beitrag im PiHole-Forum.
Ich habe schon einige Beiträge gelesen, habe bei einem sehr Interessanten und vielleicht auch problemlösenden leider nicht so ganz durchgeblickt.

Zu meinem Problem:
Auf Android-Geräten, die IPV6 unterstüzen(so gut wie jedes Gerät), wird die Werbung nicht geblockt.
Da ich leider einen Speedport W724V Typ B besitze, ist es mir nicht möglich IPV6 abzuschalten, zumal meiner Meinung nach IPV6 die Zukunft gehört.

Im folgenden habe ich ein paar Screenshots zu meiner Konfiguration angehängt.

Zunächst musste ich die EasySupport-Funktion ausschalten, da sich der Router nach Anschließen an die Telefonbuchse über das TR069-Protokoll immer automatisch konfigurieren wollte, womit es nicht möglich gewesen wäre, meinen Raspberry Pi I Model B, als DNS Server einzutragen.


Da mein Wissen sehr begrenzt ist und ich mich mit IPV6 nicht auskenne, gehe ich mal naiv davon aus, dass man mit meiner IPV6-Adresse Nichts anfangen kann.

Ebenfalls sollte man mit meiner MAC-Adresse Nichts anfangen können.
Die Option eine lokale IPV6-Adresse (ULA) zu verwenden hatte ich schon einmal aktiviert gehabt, hat aber Nichts gebracht.

Nun kommen wir zu der Konfiguration des PiHoles.
Hier handelt es sich um die Standardkonfiguration mit aktivierten DHCP-Server für IPV4 und IPV6.
Als DNS-Server, die das PiHole fragen soll, habe ich die DNS-Server der Telekom eingetragen, da diese zumindest bei mir den besten Ping haben.



Auf meinem Laptop, bei dem das Blocken der Werbung nach Aktivieren des DHCP-Servers für IPV6 funktioniert, habe ich folgende Netzwerkeigenschaften.

Bisher habe ich die Funktion des PiHoles unter zwei Android-Geräten getestet.
Mein Xiaomi Redmi Note 4 hat folgenden Netzwerkeigenschaften.

Ebenfalls habe ich die Funktionalität auf dem Smartphone meiner Freundin, einem Huawei P9 Lite getestet. Hier habe ich leider keinen Screenshot. Das Ergebnis war aber das Gleiche.

Natürlich könnte ich mein Smartphone rooten und IPV6 dementsprechend ausschalten.
Da ich aber auch für Freunde und andere Personen ermöglichen möchte, in meinem Netzwerk keine Werbung zu haben, ist das nicht problemlösend.

Hat jemand Ideen bzw. Lösungsvorschläge?

Ich freue mich über alle Antworten.

Mit freundlichen Grüßen

R4IzZ3R

0 Likes

#2

Ich habe den gleichen Router und habe im Router keine Einstellungen außer “DHCP aus” vorgenommen. Insbesondere habe ich EasySupport nicht ausgeschaltet (Mietgerät). Ich habe vollen IPv6 Internetzugang und Werbung wird auch auf Android zuverlässig blockiert.

Das ist so nicht korrekt, denn Du musst keinerlei Einstellungen diesbezüglich im Router vornehmen wenn Du den Pi-hole DHCP Server verwendest!

Bitte aktivieren und das Gerät auf dem Pi-hole installiert ist danach kurz vom Netzwerk trennen und wiederverbinden. Weitere Informationen findest Du hier:


Wenn Du mit der Erklärung da nicht klar kommst, können wir da gerne zusammen Schritt für Schritt durchgehen (dann natürlich auch auf Deutsch).


Wie gesagt, das wird nicht nötig sein. Bei mir läuft volles Dual-Stack Internet zuhause (IPv4 und IPv6 zeitgleich), der Router läuft weiterhin mit EasySupport und ich nutze den Pi-hole DHCP Server (Insiderinfo: Ich habe den Pi-hole DHCP Server hinzugefügt - passgenau auf die Probleme dieses Routermodells zugeschnitten :slight_smile: ). Wir werden das also wohl hinbekommen!

1 Like

Bitte Hilfe bei Pi-Hole mit Speedport Smart
Speedport W 724V
#3

Hallo DL6ER,
vielen Dank für deine Lösung.
In einem anderen Thread hatte ich gelesen, dass ich das PiHole nur über die Option, einen anderen Internetanbieter auszuwählen, als DNS Server einstellen könnte.
Aber da Du ja einen DHCP-Server auf dem PiHole integriert hast, ist das natürlich nichtmehr nötig, vielen Dank dafür.
Ich habe die Unterstützung von lokalen IPV6-Adressen(ULA) aktiviert und das PiHole neugestartet - WLAN auf dem Handy neu verbinden lasssen und siehe da: Die Werbung wird geblockt.
Wie zu erwarten tritt nun der Fall auf, dass Seiten sehr lange brauchen zu laden, wie im FAQ von dir beschrieben.
Ich bin mir nun nicht sicher, wie ich genau vorgehen soll.
Soll ich die ULA aus dem Router in der Config-Datei des PiHoles eintragen?
Wie verhält es sich mit den doppelten : hintereinander ?
Und die IPV6-Adresse müsste dann an welcher Stelle eingesetzt werden?
In die türkisen {}?

Du hast mir bisher viel weiter geholfen, vielen Dank!

0 Likes

#4

Ja, genau.

:: ist ein Platzhalter für eine (beliebige) Anzahl von :0000:0000: hintereinander

Ich weiß leider nicht was bei Dir türkis dargestellt wird. In der Datei /etc/pihole/setupVars.conf findest Du die Zeile

IPV6_ADDRESS=X:Y:Z

Die X:Y:Z in der obigen Zeile ersetzt Du durch die lokale ULA Adresse, die Du z.B. hier findest:

ip -6 address | grep 'global'

Die ULA Adresse fängt vermutlich bei mir mit fd an.

Danach muss die Domainliste von Pi-hole aktualisiert werden:

sudo pihole -g
0 Likes

#5

Nachdem ich es endlich geschafft habe mit dem Editor zurecht zu kommen, haben ich die IPV6-Adresse abgeändert.


Ich habe die 2. IPV6-Adresse eingetragen, die mit fd75 anfängt.
Das sieht so aus.

Danach alles abgespeichert und sudo pihole -g ausgeführt.

Leider muss ich irgendetwas falsch gemacht haben…denn leider habe ich nun wieder Werbung auf meinem Android-Gerät. Gehört der Part mit /64 mit zur IPV6-Adresse? Ich habe diesen rausgelassen, da bei der vorigen eingetragenen IPV6-Adresse ebenfalls kein /xy eingetragen war.
War das falsch?

0 Likes

#6

Nein, das ist so Okay. Hast Du mal nach pihole -g das WLAN getrennt und dann wieder neu verbunden?

0 Likes

#7

Hab ich gemacht.
Ich konnte mit verschiedenen Geräten die Funktionalität überprüfen.
Bisher geht es auf jedem Gerät, außer auf meinem Xiaomi Redmi Note 4.
Ich hatte damals, auch schon Probleme mit besagtem Gerät, als ich das PiHole unter einer Fritz!Box betrieb. Damals hatte ich die IPV6 Unterstützung nicht genutzt - trotzdem musste ich an meinem Gerät, manuell den DNS Server eintragen, um das PiHole zum Laufen zu bekommen - wohingegen das PiHole auf allen anderen Geräten problemlos funktionierte.
Ich habe gestern probiert über verschiedene Apps aus dem PlayStore meine DNS-Server abzuändern(das soll anscheinend über einen vpn-loop zum eigenen Gerät funktionieren) - aber auch das war leider ohne Erfolg.

Wie es aussieht, muss ich wohl mit Werbung auf meinem Gerät leben, immerhin sind alle anderen Geräte im Netzwerk werbefrei.

Vielen Dank für die Hilfe!

0 Likes

#8

Wir haben vor einiger Zeit schon einmal von jemandem gehört, der ein ähnliches Problem hatte - nach langem hin und her konnten wir nach aufwendigen Untersuchungen herausfinden, dass das Handy immer wieder am eingestellten DNS Server vorbei gearbeitet hat. Wenn ich mich recht erinnere, dann wurde immer wieder bei Google (8.8.8.8) angefragt, obwohl definitiv alles auf die lokale IP des Pi-hole eingestellt war.

Die Lösung war damals dann ein VPN aufzusetzen. Das Handy hat sich dann immer mit dem VPN verbunden und über dieses werbefrei. Netter Nebeneffekt: Mit einem VPN nutzt Du Deinen Werbefilter auch außerhaus. Weiterhin wäre es sicher offene WLAN-Netze zu nutzen, da sämtlicher Traffic per Standardeinstellungen erst einmal verschlüsselt zu Dir nach Hause abläuft und dann von dort ins Internet geht.

0 Likes

#9

Genau dies schien mir auch damals das Problem zu sein.
Damals konnte ich aber den DNS Server ändern, als ich am Gerät von DHCP auf statisch umgeschaltet habe. Dies kann ich selbstverständlich immernoch machen, jedoch funktioniert es dieses mal nicht. Ich habe das Gefühl, dass auch die IPV6-Anfragen an einen IPV6-DNS-Server von Google gestellt werden - zumindest leider nicht an mein PiHole.
Ich konnte mich mit dem Speedport W724V bisher noch nicht richtig auseinandersetzen.
Ist es dort ebenfalls so leicht, wie bei der Fritz!Box möglich, einen VPN-Zugang freizuschalten?

0 Likes

#10

Für die erste Grundinformation gibt es Suchmaschinen:
https://www.google.de/search?q=Speedport+W724V+VPN

0 Likes

#11

Hallo ,
tut mir leid dass ich das Thema ausgrabe.
ich habe glaub ich das gleiche Problem. ich habe einen Speedport smart und dort kamn ich zwar DHCP ausschalten, aber dies bewirkt nur dass der dhcp von IPv4 deaktiviert wird aber der dhcpv6 bleibt eingeschaltet. man kanm dhcpv6 nicht deaktivieren -
das steht auch im Telekom Forum.

nun habe ich meinen Raspberry Pi als DHCP Server eingerichtet und dieser verteilt die DNS-Serveradresse - das funktioniert perfekt mit IP V 4 und die Werbung wird folglich auf allen Geräten geblockt.

aber da dhcpv6 auf dem Router nicht deaktiviert ist und der Router sein dhcpv6 Angebot schneller sendet als mein raspberry pi, nehmen die einzelnen PCs das Angebot des Routers an und folglich erhalten meine PCs als DNS Server den Router selbst und nicht meinen Raspberry Pi.
Ich habe schon stundenlang rumprobiert und komme einfach nicht auf eine Lösung. ich weiß nicht wie ich es schaffen kann, dass die PCs die DHCP Antwort von meinem Raspberry Pi bevorzugen sollen. Der Router funkt immer dazwischen und weil alle alle Geräte IPv6 immer bevorzugen habe ich fast überall Werbung.
Ich wäre über jede Hilfe sehr dankbar.
ich habe auch hier mal eine Frage gestellt:


vielen Dank

0 Likes

#12

Hi,

probier dies mal:

  • Browser-Addon ‘Tampermonkey’ installieren
  • dieses Tampermonkey-Script einbinden. In der gelb markierten Zeile oben die IP des Routers eintragen
  • Die Router-Seite 192.168.x.x/engineer/html/lteinfo.html?lang=de im Browser öffnen

Im DNS-Bereich, wo man mit dem Tampermonkey-Script nun auch die IPv6-Server ändern kann, habe ich dann bspw. dies eingestellt:

51

fd01:ad34… die IPv6-Adresse meines Pi-hole
192.168… die IPv4-Adresse meines Pi-hole

Die beiden 2003:180… werden automatisch eingetragen und scheinen die der Telekom zu sein.

Nach den manuellen Änderungen würde ich ein Neustart des Routers durchführen.

0 Likes

Pi-hole als Dns Server beim Speedport Neo
#13

Danke für den Tipp! Leider funktioniert das Script bei dem Speedport Smart nicht. Ich versuche gerade, herauszufinden, ob man das Script umschreiben kann, aber das ist alles recht komplex. Wo hast du das Script gefunden?

0 Likes

#14

Ich habe einen Speedport Hybrid im Einsatz.

Bin mir nicht mehr sicher, woher ich es habe, könnte von jemandem hier aus dem Board gewesen sein - ich bin jedenfalls nicht der Autor.

0 Likes

#15

Hallo, ich habe alles wie hier beschrieben gemacht.
DHCP am Speedport W724V aus, IPv6 (ULA) am Speedport an.
DHCP am Pi-Hole an.
Die IPv6 (fd…) mittels ip -6 address | grep ‘global’ ausgelesen und mit sudo nano /etc/pihole/setupVars.conf in der entsprechenden Zeile eingetragen.
Dann noch sudo pihole -g und zur Vorsicht noch einmal einen Neustart des Pi-Hole.

Soweit funktioniert es, nach an- und abmelden der Clients, sie bekommen Ip-Adressen aus dem im Pi-Hole eingestellten Bereich (192.168.2.201 - 192.168.2.251). Werbung wird am Windows PC auch gefiltert, nicht jedoch am iPhone oder iPad.
Hier funktioniert es nur, wenn ich in den Einstellungen, WLAN Netzwetzwerk, DNS auf manuell umschalte und den DNS-Server “fe80::1” lösche. Siehe Screenshot.

Habe ich am Pi-Hole was falsch gemacht? Mir scheint es, dass die mobilen Geräte in der Grundeinstellung trotzdem eine IPv6 vom Router bekommen und somit die Werbung durchkommt.

0 Likes

#16

Hmm, das ist Dein Router. Der scheint also weiterhin munter sich selbst als DNS Server auszustrahlen. Nachdem ich immer mehr Kopfschmerzen mit meinem Speedport hatte, habe ich mittlerweile einen weiteren Router zwischen Speedport und meinem internen Netzwerk gesetzt und kann nun alles kontrollieren…

Immerhin schient es ja nun so, dass Du eine funktionierende Lösung für Dich gefunden hast?

0 Likes

#17

Die Lösung hat mich aber nicht zufrieden gestellt. Wahrscheinlich habe ich auch einen Fehler gemacht, da ich im Pi-Hole unter DHCP den Haken "Enable IPv6 support (SLAAC+RA) nicht aktiviert hatte.

Nun sieht es im Ipad schon besser aus, ich teste aber noch und melde mich abschließend.

0 Likes

#18

Solange dort noch fe80::1 auftaucht wird Dein Router vermutlich auch ab und an als DNS Server benutzt werden. Ich fürchte es wird hier keine saubere Lösung ohne Routeraustausch/Zwischenschaltung geben. Bei IPv6 kann jedes Gerät was hierfür zuständig fühlt ein RA Paket verschicken in dem DNS Server angegeben werden. Die Geräte im Netzwerk können sich dann frei entscheiden ob und welche angekündigten DNS Server angenommen werden. IPv6 ist eben viel mehr auf Selbstmanagement aufgebaut und nicht so zentralistisch wie IPv4 mit seinem autoritären DHCP Server…

Dein Router verschickt vermutlich solch ein RA Paket ind dem er sich selbst als DNS Server anpreist und Du kannst es dort nicht abschalten.

0 Likes

#19

Also das setzen des Hakens “Enable IPv6 support (SLAAC+RA)” am Pi-Hole hat bei mir dazu geführt, dass ich keine Werbung mehr auf den Windows-PCs, IPads und Macs habe.
Wegen fehlender Hardware kann ich Android nicht testen.

0 Likes

#20

‘fe80::1’ als weiterer DNS Server betrifft auch den Speedport Hybrid, zumindest auf einem iPhone und iPad.

Auf beiden Geräten habe ich nicht ‘Automatisch’ als DNS Server ausgewählt, sondern ‘Manuell’ und bei den IPs dann die vom Pi-hole (192…)

0 Likes