Pi-Hole sofort nach Start wieder offline

Wenn ich über die Weboberfläche über "Enable" Pi-Hole starte zeigt er mir sofort danach im Status wieder offline an.
Mein Token ist: https://tricorder.pi-hole.net/9wo9dz2g18

Kennt jemand das Problem. Pi-Hole sollte auf dem aktuellen Stand sein.

Hinweis: ich habe Pi-Hole temporär als DNS heraus genommen, da es ja eh nicht funktioniert.

Das liegt vermutlich an diesem doppelten Eintrag:

*** [ DIAGNOSING ]: Setup variables
    BLOCKING_ENABLED=true
    BLOCKING_ENABLED=false

Außerdem verteilt dein FritzBox-Router sich selbst als DNS-Server:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   
   * Received 548 bytes from eth0:192.168.178.1
     Offered IP address: 192.168.178.59
     DHCP options:
      Message type: DHCPOFFER (2)
      server-identifier: 192.168.178.1
      router: 192.168.178.1
      dns-server: 192.168.178.1
      domain-name: "fritz.box"

Zur Konfiguration einer FritzBox für Pi-hole via IPv4 lohnt ein Blick auf https://docs.pi-hole.net/routers/fritzbox-de/.

Außerdem wurde Pi-hole für die Verwendung einer öffentliche IPv6-Adresse konfiguriert (aus dem Bereich 2000::/3), die aufgrund der Änderung des IPv6-Präfix nicht mehr gültig ist.

Für Pi-hole ist eine ULA-Adresse (aus dem Bereich fd00::/8) empfehlenswert, bei der das Präfix fest vorgegeben wird. Ein entsprechendes ULA-Präfix lässt sich in der FritzBox konfigurieren.

Sobald dies erfolgt ist, lässt sich die ULA-Adresse des RPis auf demselben z.B. über folgendes Kommando anzeigen:

ip -6 show address

Anschliessend solltest Du Pi-hole über

pihole -r

und Reconfigure für die IPv6-ULA-Adresse konfigurieren.

Danach solltest Du nochmals prüfen, ob /etc/pihole/setupVars.conf immer noch zwei Einträge für BLOCKING_ENABLED enthält und ggf. die zweite dieser Zeilen aus der Datei löschen.

Danke. Es läuft wieder. Alles hat bestens mit deiner Hilfe geklappt.