Pi hole server in VM with two network interfaces

Please follow the below template, it will help us to help you!

Expected Behaviour:

dnsmasq should listen and answer through the same interface/IP address

Actual Behaviour:

dnsmasq listens to ens0p9/ (right choice) but replies to ens0p3/ (wrong choice). The latter virtual interface is a virtual network to enable network communication between the host and VM.

Debug Token:

My problem is most probably not related to pi-hole but with the network configuration. When I delete the ens0p3 interface from the VM, everything works perfectly, but I lose network communication between host and guest (VM). Please excuse me occupying this forum with this question that is unlikely to be a pi-hole related issue. I just thought somebody here may have tried this and can give me an idea since I couldn't find a solution after several hours of searching. The VM running the pi-hole server is archlinux based, therefore debugging option is not available. I understand if you are unable to help, thank you for considering.

Please send us the token generated by

pihole -d

or do it through the Web interface:

And also, what do you have set here:


1 Like

Thank you for your prompt reply. The problem solved itself once I added ens0p3 interface to VM again. Perhaps doing this helped defined it as the non-default interface, but this is a wild guess.
Interface listening behavior option has always been selected as ens0p9, the right, bridged interface. Thank you also for teaching me how to debug using the web interface.
Most of all, thank you for developing such a useful and easy-to-install and easy-to-use tool!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.