Pi-Hole or admin console issue?


Please follow the below template, it will help us to help you!

Expected Behaviour:

Expected to see number of sites being blocked (0) and the percentage of sites being blocked/queries (0%).

Actual Behaviour:

Admin console is reporting 0 Queries Blocked & 0 Percent Blocked. My “Black listed” sites are not getting blocked either.

Debug Token:


I just recently upgraded to Stretch and the VNC window froze during the upgraded.


The Pi-hole IP address is set to, but queries against that address do not resolve. What is the result of dig flurry.com @ from a client or from the Pi-hole device?


Thanks Dan,

; <<>> DiG 9.10.3-P4-Raspbian <<>> flurry.com @
;; global options: +cmd
;; connection timed out; no servers could be reached

It looks like my Pi-Hole has re-assigned the address of the Raspberry Pi. I ran the dig command under the re-assigned IP address and go this…

; <<>> DiG 9.10.3-P4-Raspbian <<>> flurry.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28664
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4096
;flurry.com. IN A

flurry.com. 2 IN A

;; Query time: 0 msec
;; WHEN: Sat Jul 14 07:34:44 EDT 2018
;; MSG SIZE rcvd: 55

;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31725

So now the question is how do I get the Pi-Hole running back on 121 or is it best to change the code to run on 38?

  • Z


Take a look at /etc/dhcpcd.conf and see what the static lines show as should be the address for the Pi-hole. And then check /etc/network/interfaces to make sure that the interface is set to manual. Finally, check ip -4 address to see if the IP address is dynamic or static. It sounds like the device is still acting as a DHCP client even though it should be statically assigned the address.


I am unable to run any of the commands you suggest, none of them are recognized with either “sudo” or “nano”. What are my options from here? Is it best to re-image my SD card and start over?


You need to cat the files, some of them with sudo cat if they are not viewable to the pi user. They are not commands to execute.


The /etc/dhcpcd.conf command yields nothing useful as it seems to be a sample file?!

the interfaces are set to “manual”.


There are no lines in /etc/dhcpcd.conf that start with static and are uncommented?


If this is the case, run pihole -r and reconfigure the device to use the IP address you would like. Looking over your debug log shows issues with lighttpd as well. My suggestion at this point is to just start over, flash a new SDCard with Stretch and install from there.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.