Pi-Hole not working w/ Orbi Satellite Only

Expected Behavior:
When any device (tested with iPhone) is connected to the Orbi Satellite (upstairs in house), ads should not appear.

Actual Behavior:
When any device is connected to the Orbi Satellite, ads appear. There are no issues when devices are connected to the Orbi Router (downstairs).

  • Orbi RBR50 + one Satellite (v2.3.5.30 Firmware), DHCP disabled
  • Router and Satellite rebooted multiple times
  • iPhone rebooted multiple times
  • Pi-Hole acting as DHCP server

Debug Token:
https://tricorder.pi-hole.net/1a9oh59u13

From your debug your pi-hole is functioning correctly. There is something on your network that is making the dns requests that you are seeing that is resulting in the ads that is not being blocked or serviced by your pi-hole

Hmmm. Not sure where to go from here. There aren’t any additional settings to tweak with the satellite unit, only the router.

Pi-Hole

  • Using Cloudflare DNS
  • Using reserved IP address

Netgear Orbi

  • Static IP
  • Also using Cloudflare DNS, but this shouldn’t matter because Pi-Hole is the DHCP server right?
  • Dynamic DNS turned off

This matters. Pi-Hole should be the only DNS. If you specify a DNS other than Pi-Hole, clients will use it.

1 Like

Interesting.

My two options in Netgear Orbi settings are “Get Automatically from ISP” or “Use These DNS Servers: Pri/Sec/Ter (fill it in yourself)”

For some reason, I cannot select “Get Automatically from ISP” and I can’t leave the DNS fields blank. Do I put the IP of my Pi as the DNS?

Enter the Pi-Hole IP multiple times, or put in an unused IP from your LAN if it won’t allow a repeated IP.

1 Like

I think that did it! I’ll keep an eye on it.

Thanks so much!