Pi-Hole fails to install required components

I only installed pi-hole and it refused to alunch

Please post a fresh debug token. The old one has expired after 48 hours.

Also, please restate your problem here so users don't have to go to GitHub to read the problem.

Here you go. I hope it helps:

https://tricorder.pi-hole.net/rl07gvath4

If I have missing components will be the resolution be these to be added to the dependencies as Linux really does not care what GUY runs on top ...

Run pihole -r and select the repair option.

Just finished, but the result is the same. Does not open:

https://192.168.0.7/

[sudo] password for olimex:

  [βœ“] Root user check

        .;;,.
        .ccccc:,.
         :cccclll:.      ..,,
          :ccccclll.   ;ooodc
           'ccll:;ll .oooodc
             .;cll.;;looo:.
                 .. ','.
                .',,,,,,'.
              .',,,,,,,,,,.
            .',,,,,,,,,,,,....
          ....''',,,,,,,'.......
        .........  ....  .........
        ..........      ..........
        ..........      ..........
        .........  ....  .........
          ........,,,,,,,'......
            ....',,,,,,,,,,,,.
               .',,,,,,,,,'.
                .',,,,,,'.
                  ..'''.

  [βœ“] Update local cache of available packages
  [i] Existing PHP installation detected : PHP version 7.4.3
  [i] Repair option selected

  [βœ“] Checking apt-get for upgraded packages... up to date!

  [i] Installer Dependency checks...
  [βœ“] Checking for dhcpcd5
  [βœ“] Checking for git
  [βœ“] Checking for iproute2
  [βœ“] Checking for whiptail
  [βœ“] Checking for dnsutils

  [βœ“] Supported OS detected
  [i] SELinux not detected
  [i] Performing reconfiguration, skipping download of local repos
  [βœ“] Resetting repository within /etc/.pihole...
  [βœ“] Resetting repository within /var/www/html/admin...
  [i] Main Dependency checks...
  [βœ“] Checking for cron
  [βœ“] Checking for curl
  [βœ“] Checking for iputils-ping
  [βœ“] Checking for lsof
  [βœ“] Checking for netcat
  [βœ“] Checking for psmisc
  [βœ“] Checking for sudo
  [βœ“] Checking for unzip
  [βœ“] Checking for wget
  [βœ“] Checking for idn2
  [βœ“] Checking for sqlite3
  [βœ“] Checking for libcap2-bin
  [βœ“] Checking for dns-root-data
  [βœ“] Checking for libcap2
  [βœ“] Checking for lighttpd
  [βœ“] Checking for php7.4-common
  [βœ“] Checking for php7.4-cgi
  [βœ“] Checking for php7.4-sqlite3
  [βœ“] Checking for php7.4-xml
  [βœ“] Checking for php7.4-json
  [βœ“] Checking for php7.4-intl

  [βœ“] Enabling lighttpd service to start on reboot...
  [βœ“] Checking for user 'pihole'

  [i] FTL Checks...

  [βœ“] Detected ARMv7 processor (with hard-float support)
  [i] Checking for existing FTL binary...
  [i] Latest FTL Binary already installed (v5.8.1). Confirming Checksum...
  [i] Checksum correct. No need to download!
  [βœ“] Installing scripts from /etc/.pihole

  [i] Installing configs from /etc/.pihole...
  [i] Existing dnsmasq.conf found... it is not a Pi-hole file, leaving alone!
  [βœ“] Copying 01-pihole.conf to /etc/dnsmasq.d/01-pihole.conf

  [i] Installing blocking page...
  [βœ“] Creating directory for blocking page, and copying files
  [i] Backing up index.lighttpd.html
      No default index.lighttpd.html file found... not backing up

  [βœ“] Installing sudoer file

  [βœ“] Installing latest Cron script

  [βœ“] Installing latest logrotate script
  [i] Backing up /etc/dnsmasq.conf to /etc/dnsmasq.conf.old
  [βœ“] man pages installed and database updated
  [i] Testing if systemd-resolved is enabled
  [i] Systemd-resolved does not need to be restarted
  [i] Restarting lighttpd service...
$ ls -lt

drwxr-xr-x 129 root root   12288 Jul  9 22:08 etc
drwxr-xr-x  31 root root     960 Jul  9 22:07 run
drwxr-xr-x   2 root root    4096 Jul  8 10:12 boot
drwx------   3 root root    4096 Jul  7 10:01 root
drwxr-xr-x  17 root root   13700 Jul  7 10:00 dev
dr-xr-xr-x 210 root root       0 Jul  7 09:59 proc
dr-xr-xr-x  12 root root       0 Jul  7 09:59 sys
drwxr-xr-x   3 root root    4096 Jul  7 09:24 opt
lrwxrwxrwx   1 root root      14 Jul  6 20:00 home -> /mnt/Disk/home
lrwxrwxrwx   1 root root      13 Jul  6 19:59 tmp -> /mnt/Disk/tmp
lrwxrwxrwx   1 root root      13 Jul  6 19:58 srv -> /mnt/Disk/srv
lrwxrwxrwx   1 root root      13 Jul  6 19:53 var -> /mnt/Disk/var
drwxrwxrwt  15 root root    4096 Jul  6 19:45 tmp.old
drwxr-xr-x   3 root root    4096 Jun 20 02:04 mnt
-rw-------   1 root root 2056192 Jun 19 14:09 core
drwx------   2 root root   16384 May 13 17:40 lost+found
drwxr-xr-x  12 root root    4096 May 13 17:25 var.old
drwxr-xr-x  11 root root    4096 May 13 17:01 usr
drwxr-xr-x   3 root root    4096 May 13 14:45 home.old
-rw-r--r--   1 root root    8192 May 13 14:43 uboot.env
drwxr-xr-x   2 root root    4096 May 13 14:25 media
lrwxrwxrwx   1 root root       7 May 13 14:25 bin -> usr/bin
lrwxrwxrwx   1 root root       7 May 13 14:25 lib -> usr/lib
lrwxrwxrwx   1 root root       8 May 13 14:25 sbin -> usr/sbin

Hi, any progress on this one? It worked perfectly on Ubuntu 18.

Are you trying with https? Pi-hole is http only. Try http://pi.hole/admin/index.php?login

These result the same output ( This site can’t be reached 192.168.0.7 refused to connect.):

  1. http://pi.hole/admin/index.php
  2. https://192.168.0.7/
  3. http://192.168.0.7/ This is converted to https from the browser

Pi-hole version is v5.3.1 (Latest: v5.3.1)
AdminLTE version is v5.5 (Latest: v5.5)
FTL version is v5.8.1 (Latest: v5.8.1)

Only the web interface does not work for me. I would rather ditch it as I use SSH console mostly :wink:

Browser redirection to HTTPS may happen if your webserver serving Pi-hole would instruct your browser to do so (Pi-hole's own lighttpd won't do that), or if pi.hole somehow entered your browser's HSTS list, or if a browser plugin would enforce HTTPS.

For any of those, you'd need to revert the respective setting or to declare an exception for pi.hole.

No need. Got it running all in the console. No fancy website needed :wink:
You can find my setup here!

|???(?)_|?|_  ___|?|___        Core: v5.3.1.
| ?_/?|_| ' \/ _ \ / -_)        Web: (not installed)
|_| |_| |_||_\___/_\___|        FTL: v5.8.1.
 β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”β€”
  Hostname: a20-olinuxino      (Ubuntu Fossa 20.04)
    Uptime: 8 days, 10:35:44
 Task Load: 0.45 0.26 0.18     (Active: 3 of 101 tasks)
 CPU usage: 3%                 (2x 960 MHz @ 43c)
 RAM usage: 34%                (Used: 336 MB of 998 MB)
 HDD usage: 11%                (Used: 3 GB of 29 GB)
  LAN addr: 0.0.0.0            (Gateway: 192.168.0.1)
   Pi-hole: Active             (Blocking: 4771284 sites)
 Ads Today: 16%                (Total: 262 of 1594)
Local Qrys: 71%                (2 DNS servers)
   Blocked: hidden
Top Advert:
Top Domain:
Top Client: 192.168.0.100

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.