Pi-Hole DNS is reporting Amazon.com, and others, as IP of Pi-Hole


#1

Expected Behaviour:

DNS should report correct external IP for Amazon.com.

Actual Behaviour:

Pi-Hole DNS is reporting Amazon.com as internal IP of Pi-Hole.

Ping from internal computer shows Amazon.com as 176.32.103.205.
Navigating to Amazon.com from a browser fails until Pi-Hole is disabled. (Even if Amazon.com is White-listed)

Watching the log in real-time, I see output similar to:

query [A] amazon.com from 172.26.100.1
reply amazon.com is 172.26.100.2

Where 172.26.100.1 is my internal router, and 172.26.100.2 is the Pi-Hole IP

Debug Token:

Token: gdev835967


#2

what happens when you view it in the query log. the blocklists are community maintained and there is a chance one has added that domain you may need to whitelist it


#3

Well, I’m at work now and don’t have a way to access my pi-hole from here, so I’ll check when I get home.

But, I did try to view the query logs last night, and I think something may be messed up with the logging. There were some logs present, but the newest log was from December 2017. I even disabled and flushed the logs, then re-enabled query logging, but for some reason, those logs remained, and no newer logs populated.

I may end up just flashing the SD card, and re-installing, but before I did that, I wanted to see if anyone has run across something similar.


#4

we have back when 3.2.1 came out we discovered different Locale settings could cause whitelist not to be respected.
You are on Raspbian Jessie which due to some DNSMasq issues is EOL for support. one thing you could try is upgrading to stretch and/or running the dev branch with FTLDNS


#5

I can’t find your debug token on our server. Can you try uploading it again?


#6

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.