Pi-hole disabled while it's not

Read this one: Pi-hole disabling itself/won't enable blocking
Same? That's probably 4.x, I'm on 5.0
There is no setting as mentioned in (my) v5.0.
Pi-hole is blocking.

Pi-hole version is v5.0 (Latest: v5.0)
AdminLTE version is v5.0 (Latest: v5.0)
FTL version is v5.0 (Latest: v5.0)

The web UI shows
(red dot) Offline
(play button) Enable

pihole status
[✓] DNS service is running
[✗] Pi-hole blocking is Disabled

pihole enable
[i] Blocking already enabled, nothing to do

Today I noticed it maybe had something to do with javascript. uMatrix was in the the way I think.

Back to square one again. Even disabling uMatrix doesn't help.

Please post the token generated by

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

My token https://tricorder.pi-hole.net/lhlyxjdv5z

What is the specific problem now? Pi-hole works but the GUI shows it disabled?

Exactly (see my first post)

Please edit /etc/pihole/setupVars.conf and delete one of these two lines:

BLOCKING_ENABLED=true
BLOCKING_ENABLED=false

They are exclusive and cause issues when both values coexist at the same time. Afterwards, run

pihole restartdns

Thx.

Did read this solution before but then my terminal window was not full screen so it appeared these lines were not in the file (a '@' on each line from line x onward)

This time same thing but you have my token so it has to be in the file and I came with the 'brilliant' idea to maximize the window. :facepalm:

Sorry.