Pi-hole conflicting with FritzOS 7.26?

Hi, my pi-hole runs on a Raspberry Pi Zero W with Raspbian 10. In my Fritzbox 7490, the pi-hole is configured as primary DNSv4 server and DNS over TSL is activated. Until recently, everything worked like a charm. Things changed after updating my router.

Usually, I update the pi-hole via SSH using

sudo apt-get update && sudo apt-get upgrade -y && pihole -up

Currently this is what happens:

Temporary failure resolving 'raspbian.raspberrypi.org'
unable to access 'https://github.com/pi-hole/pi-hole.git/': Could not resolve host: github.com
Retrieval of supported OS list failed. dig failed with return code 10.
Unable to determine if the detected OS (Raspbian 10) is supported_

I tried uploading the debug token, but this didn't work either:

curl failed, falling back to netcat for transmission.
nc: getaddrinfo for host "tricorder.pi-hole.net" port 9999: Temporary failure in name resolution

Help would be appreciated.

This could indeed be a temporary DNS failure, so a simple retry may work.

If it doesn't, you could check the DNS servers your RPi Zero is using:

sudo nano /etc/resolv.conf

Then edit the nameserver line to nameserver 9.9.9.9 or your preferred third party DNS service, save and exit, and retry updating.

Changing the nameserver in resolv.conf fixed the problem.
Thank you very much.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.