Pi-hole apparently working but not blocking ads

Hello.

I have installed and configured Pi-hole on a Raspberry Pi 4 with Raspbian OS. The Pi-hole DNS has a static IP 192.168.1.100. I am using the Wi-fi network.

I am trying to use it to block ads on my Windows 11 laptop but it is not working.

Info command ipconfig on my laptop:

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . : Home
Description . . . . . . . . . . . : Realtek RTL8822CE 802.11ac PCIe Adapter
Physical Address. . . . . . . . . : CC-6B-1E-9D-DF-87
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:8a0:6ca6:6800:5d06:30ee:f2f0:4919(Preferred)
Temporary IPv6 Address. . . . . . : 2001:8a0:6ca6:6800:ec09:9048:154e:582a(Preferred)
Link-local IPv6 Address . . . . . : fe80::5d06:30ee:f2f0:4919%12(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.90(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 5 de maio de 2022 13:04:44
Lease Expires . . . . . . . . . . : 5 de maio de 2022 15:35:26
Default Gateway . . . . . . . . . : fe80::5afc:20ff:feb3:23ff%12
192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DHCPv6 IAID . . . . . . . . . . . : 114060062
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-29-84-DC-85-CC-6B-1E-9D-DF-87
DNS Servers . . . . . . . . . . . : 2001:8a0:6ca6:6800::1
192.168.1.100
NetBIOS over Tcpip. . . . . . . . : Enabled

Debug Pi-hole: https://tricorder.pi-hole.net/QLTbQPWh/

Pi-hole Dashboard:

I have added a lot of adlists to try to block the unblocked ads. I have 55 adlists and 5 738 170 domains listed.

DNS Settings:

Pi-hole in not being used as DHCP Server.

Still not blocking ads from:
www.forbes.com

www.cnn.com

www.canyoublockit.com

Appreciate the help.

I would seem your router is advertising its own IPv6 address as DNS server.
Thus, devices may by-pass Pi-hole via IPv6.

You'd have to find a way to configure your router to advertise your Pi-hole host machine's IPv6 as DNS server instead.

You'd have to consult your router's documentation sources on further details for its IPv6 configuration options. Note however that some few router models wouldn't support IPv6 DNS configuration, and of those that do, a few show a misbehaviour of distributing their own IP address along with any custom address regardless.

If your router doesn't support configuring IPv6 DNS, you could consider disabling IPv6 altogether.

If your router doesn't support that either, your IPv6 capable clients will be able to bypass Pi-hole via IPv6.

In addition, your Pi has no active network configurations:

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the eth0 interface.

[✗] No IPv6 address(es) found on the eth0 interface.

and your router is distributing its own IP as DNS server, and not advertising the Pi-hole IP:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   
   * Received 280 bytes from wlan0:192.168.1.254
     Offered IP address: 192.168.1.100
     Server IP address: N/A
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      server-identifier: 192.168.1.254
      lease-time: 3600 ( 1h )
      netmask: 255.255.255.0
      router: 192.168.1.254
      dns-server: 192.168.1.254
      domain-name: "Home"
      --- end of options ---
    
   DHCP packets received on interface eth0: 0
   DHCP packets received on interface lo: 0
   DHCP packets received on interface wlan0: 1
1 Like

Thank you for your help.

It was the IPv6 address configuration. Now it is working well.

Thank you very much.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.