Pi Crashing every few hours


I’m all out of ideas of things to solve a crashing issue and looking for thoughts.

Pi Zero W
Raspberry Pi OS

Actual Behaviour:

Every couple of hours the Pi crashes, unresponsive, no hdmi output, wireless router shows it is no longer connected.

We’ve had the Pi Zero W and power supply replaced with RMA and also tried several different brand SD Cards
The Pi sits about 1 metre away from the router.

I’ve tried running Pi OS without Pi Hole and it was stable.

This install was crashing constantly, I then removed the Bluetooth service and it seemed stable for a week or so. However, yesterday it started again, the only way to get it back online is by removing the power.

I’ve also disabled screen timeouts, set wlan power save off.
Since the crashes started again yesterday, I updated the Pi OS and pihole today but the crashing continues. I cleared the FTL database today in case it was something to do with the latest pihole update with FTL.

No other services installed except what’s in the pihole package.
Pi Hole is acting as the DHCP server with the router DHCP disabled.

The temp sits around 26c, less than my other pi’s.

Debug Token:


Any help would be great please as I can’t think of what else to try.

Many thanks!

Hi Pluto,

Out of curiosity: Is this ticket the same as this one on Reddit? There are some really in-depth replies there when it comes to the OS side of things.

What's the specific model of your Pi? How are you running pihole (native/docker run/docker compose)?



Your debug log looks normal, showing your Pi-hole to be fully operational, with no hints of crashes.

Why would you think that it is Pi-hole that's constantly crashing?
Did you observe respective log messages that would suggest so, e.g. by scrutinising sudo journalctl -p err or Pi-hole's logs at /var/log/pihole*?

Thanks for answering.

Not me on Reddit but I will take a look in case it’s something I haven’t read.

I installed using the manual download and install method from the install guide.

Running on the latest pi zero with, BCM2835, and 512mb.
It has a 5.1V 2.5A power supply.

How odd, the only reason I say pi-hole is after the first install kept crashing I reinstalled pi os and left it for a few days, after installing pi hole it started to crash.

Both ram and processor seem to running at a few % usage when everything is going.

I had a look through the logs a while back. It seems that when the pi locks up it doesn’t log it as it just stops.

I’m really stumped on this one.

I have pihole working perfectly for months at another place which i installed the same way.

The only difference being the ISP and router, I can’t see it being that though as if it dropped WiFi it wouldnt leave it unresponsive to keyboard input and monitor output, would it?

I’m just getting someone in that house to move it to the extension.

Newer electrical wiring than the rest of the house.

I don't think that its your PSU, and brown-outs would probably register in the logs.
You could check your logs for recent occurences of under-voltages:

zgrep -ni “voltage” /var/log/syslog*

Without any logs or other leads, that'll be a tough one to track down.
It'll also be hard to provide evidence to attribute the failures to Pi-hole.

The most common misconfiguration that could actually make Pi-hole seem unresponsive (but not crash it) would be a DNS loop.
There are however no hints that this would apply in your case, as your debug log shows you have not configured your router as one of Pi-hole's upstreams, nor did you enable Conditional Forwarding.

Are there other electrically noisy devices in close proximity to your Zero?
E.g. microwaves or some smart device wifi protocols like ZigBee are awfully close to the 2GHz band. Can you correlate such activities with the times of failure?
Also, did you configure a WiFi country for your Zero?

This wouldn't explain loss of KMV, but it could interfere with your WiFi and explain loss of DNS resolution as well as Pi-hole's UI access via client browsers.

1 Like

So I’ve pulled the unit back to my place.

Joined it my local WiFi network and it’s been perfect for 24 hours. It can’t access the internet but its working and seems stable.

Kernel log doesn’t report anything from crash time to restart. log stopped with.

Shortened version as I have to type

Random: 7 urandom warning missed due to ratelimiting 
802.1q vlan support v1.8
Adding 102396k swap on /var/swap
Brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled

Brcmfmac: brcmf_cfg80211_set_power_mgmt: power save disabled

Then nothing

Syslog continues logging with
Starting clean php session files
Every 30 mins but no errors or warning and says it’s successful.

So it seems it’s sort of alive but not.

No voltage warning anywhere.
We’ve tried a few locations, the last being in its own room with no electrical devices.

The problem I have, it’s come from a really non technical household so trying to get them to test and keep logs of when it crashes is a nightmare. They only use the pc once a day if that.

WiFi country is good,.

Thanks for you help above! The fact it’s stable here although not tested on the internet say it’s probably not a pihole thing.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.