OpenVPN Slow [Resolved]


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Slightly faster OpenVPN speeds from remote clients

Actual Behaviour:

VPN speed is 18Mbps/30Mbps; it should be a little higher (25Mbps?). WAN up at home is 34Mbps.

Debug Token:

https://tricorder.pi-hole.net/75i4m33jd0!

Not Pi-hole specific, I know. I’m running on a Pi 3 B+; DNS + DHCP. PiVPN setup; everything works. However, my OpenVPN connection is much slower than it should be. htop shows it using 50% CPU usage.

Here is my openvpn config:

dev tun
proto udp
port 1194
ca /etc/openvpn/easy-rsa/pki/ca.crt
cert /etc/openvpn/easy-rsa/pki/issued/server_CT6pok7tKt8scANd.crt
key /etc/openvpn/easy-rsa/pki/private/server_CT6pok7tKt8scANd.key
dh none
topology subnet
server 10.8.0.0 255.255.255.0
push “dhcp-option DNS 192.168.2.60”
push “redirect-gateway def1”
client-to-client
keepalive 1800 3600
compress lz4-v2
remote-cert-tls client
tls-version-min 1.2
tls-crypt /etc/openvpn/easy-rsa/pki/ta.key
cipher AES-256-CBC
fast-io
sndbuf 524288
rcvbuf 524288
push “sndbuf 524288”
push “rcvbuf 524288”
auth SHA256
user nobody
group nogroup
persist-key
persist-tun
crl-verify /etc/openvpn/crl.pem
status /var/log/openvpn-status.log 20
status-version 3
syslog
verb 3

Any ideas for how I can speed it up?


#4

you can try using the guide found here: https://docs.pi-hole.net/guides/vpn/overview/ to configure your VPN to only pass DNS


#5

Yes, that worked! Thanks.

I commented out push “redirect-gateway def1” from server.conf and restarted the service.