Only admin console is reacheable, no internet after set the DNS


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

[Replace this text with what you think should be happening]

Actual Behaviour:

I configured a Raspberry Pi Zero W at my home for use at my parents home. I changed the IP to one of the range at my parents, and changed the Wifi network configuration.
So far so good.
But when I connect the Pi to my parents network, only the Admin console page is available.
When I set the DNS to the Pi-hole IP address, for example at my phone, I do not have Internet connection.

I also installed Teamviewer at he Pi, at my home network that works fine. But at my parents network Teamviewer is also not available.

Do I need for some reason configure the Pi-Hole at the network where it will be used?

What can be the problem here?

Debug Token:

[Replace this text with the debug token provided from running pihole -d (or running the debug script through the web interface]


#2

How did you configure your devices to use Pi-hole for their DNS server?


#3

Each device in my parents network must be configured manually.
Because the router did not support to change the DNS address.

Earlier the Pi-Hole works fine. But because the SD card was broken, I has to reinstall all the stuff.
The first time I installed Pi-Hole directly in my parents home network. After that it worked immediately.

Maybe there is a setting which is not ok?
The Wifi connection is ok, because I can login to the Pi-Hole admin page.
I can connect a screen to the Raspberry and try to repair the installation?


#4

How is the Pi-hole set-up to listen on the DNS requests?
(Under Settings/DNS/Interface Listening behavior)

See if setting it up to Listen to all (one hop away) fixes your issue.

image


#5

I can check this as soon as possible.

What I don’t understand is that Teamviewer not accessible is.
In my own home network, during installation of Pi-hole, I tested Teamviewer to connect remotely, and everything works fine.
So, it looks like that there are some more problems in the raspberry pi?


#6

Unfortunately, the option ‘Listen on all devices’ won’t work.
What I also note is that the admin page loads very slow, and sometimes the page will freeze.
So it look likes that there are more problems than only the above setting.

Teamviewer don’t work also.
I try the Raspberry in my own network again, otherwise I setup Pi-Hole from scratch directly in my parents network,


#7

This might be due to a failed DNS request.

run a pihole -r at your parents and select reconfigure.