One Device bypass Pihole

Code for /etc/dnsmasq.d/04-bypass.conf

dhcp-option=tag:SmartDns,6,208.67.222.220
dhcp-host=MA:CA:DD:R:ES:SS,set:SmartDns

Expected Behaviour:

The computer I have selected (via mac address) should be not using pihole and should be using the DNS I have set.
I have run sudo service pihole-FTL restart. What am I missing?
Edit: using Pihole for DHCP

Actual Behaviour:

Its not using the DNS is have set.

You need to substitute the MAC address of you client here - notice the spelling of “MAC Address” - this is a placeholder.

Yes I know, I just used that as a place holder. I just didn’t want to post the my mac address because I could not remember if it’s save or not.

A few things to try:

  1. Run this command from the Pi terminal to check your syntaxes - might be a weird line feed or something:

pihole-FTL dnsmasq-test

  1. Renew the DHCP lease on the client in question.
1 Like

try with dhcp-option-force … see if that pushes it properly.

Thanks, The renew of the DHCP worked.