Number of checked/blocked domains dropped all of a sudden in docker on Synology NAS

Expected Behaviour:

pihole in docker on Synology NAS (no changes to docker install); no changes made
pihole used to block lots on iPhones and SmartTV

Actual Behaviour:

Visible in above image after 10:30

The Adlist has also increased; this seems to be an automated process, I have no control over?! Hence, it may have updated itself and since then behaves like this?

Debug Token:

??

List are updated once a week.

Please upload a debug log and post just the token URL that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

1 Like

Thank you for your reply :slight_smile:

The debug token is: https://tricorder.pi-hole.net/Qp6999vF/

The debug log shows Pi-hole's IP is 192.168.1.126:

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface:
    192.168.1.126/24

But it also shows your router is advertising a different IP as DNS server:

      router: 192.168.1.1
      dns-server: 192.168.1.8

This means your devices will use 192.168.1.8 (unless you manually set a different DNS on a device).

Did you recently change your router's configuration?

Gravity is updated Sunday morning at a time randomly selected (during install) between 0300 and 0500 your local time. In your case, this is the cron line that does the weekly gravity update:


-rw-r--r-- 1 root root 1.7K Nov 21 03:07 /etc/cron.d/pihole
   20 3   * * 7   root    PATH="$PATH:/usr/sbin:/usr/local/bin/" pihole updateGravity >/var/log/pihole/pihole_updateGravity.log || cat /var/log/pihole/pihole_updateGravity.log

Your Pi-hole updates gravity at 0320 your local time every Sunday.

It is normal for the number of domains on any public blocklist to change on a regular basis. When your gravity updates, you capture the new updates to the list(s).

Thank you for looking into this.

I made no changes to any roouter/DNS/DHCP config...

Default DNS is .8, but I use static DNS assignments with .127
... like so:

host maxg-pendo {
        # MaxG's Pendo Pad
        hardware ethernet 08:d8:33:4b:51:65;
        fixed-address 192.168.1.30;
        option domain-name-servers 192.168.1.127;
}

I have, since my OP re-installed the pi-hole docker container, which made no difference.
After the debug log ran, I could see it blocked the two test domains. Meaning blocking is working.

Hmm, I started typing my previous post yesterday, but forgot to send it.

Early morning heere in Queensland, Austrlai, and I just looked at the pihole screen.

What the heck is going here? It seems to be working again since 22:50.

I was in bed at the time, hence, I did not make an change, other than re-installing the docker container as stated in post #6 (the one above).

Go figure; I have no idea why it stopped, and why it started.

In any case; thank you for your support.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.