Not seeing any queries?


The server is performing it’s DNS filtering. Queries through it are working. The web UI just isn’t showing them.

When visiting the http://ip.of.pihole.server/admin/ webpage the Queries boxes all show a revolving circle that never updates.

Likewise, when visiting the Query log page nothing shows up.

Please follow the below template, it will help us to help you!

Expected Behaviour:

See queries

Actual Behaviour:

Busy circle icon never stops.

Debug Token:



Is this just limited to a single browser on a single client?

Clear the cache on that browser, restart the browser and reload the admin web page.


Should have mentioned, same problem on three different browsers on two different machines. Seems to be server specific. Rebooting the pi-hole server didn’t change the problem.


What is the exact address you are trying to load in the browser?



The first one just shows the spinning circle arrows icons in all the data boxes (queries, clients, types, etc). The second shows no query list.

As I mentioned, it’s performing pi-hole DNS filtering, just not showing it on the web admin pages.


What is the output of echo ">stats" | nc localhost 4711

Do you see any stats at all on the web interface? Does it show as enabled or disabled?

root@pi-hole:/var/log# echo ">stats" | nc localhost 4711
domains_being_blocked 37
dns_queries_today 6691
ads_blocked_today 104
ads_percentage_today 1.554327
unique_domains 380
queries_forwarded 4641
queries_cached 1943
clients_ever_seen 16
unique_clients 16
dns_queries_all_types 7034
reply_NODATA 394
reply_NXDOMAIN 445
reply_CNAME 1862
reply_IP 4241
status enabled


The web interface works for what seems like everything BUT the stats and logging pages. Here’s a screenshot of the dashboard page. No matter how long I leave that page up it never stops spinning the circle. I’ve tried loading the page on this computer using three different browsers (Chrome, Firefox, even IE) and they’re all getting the same thing… just the spinner.


This is abnormal, but perhaps not related to the problem you are seeing. With your subscribed blocklists, you should have approximately 126K domains being blocked.

Run this command and select repair,

pihole -r

then re-run echo ">stats" | nc localhost 4711


root@pi-hole:/var/log# pihole -r

  [✓] Root user check

         :cccclll:.      ..,,
          :ccccclll.   ;ooodc
           'ccll:;ll .oooodc
                 .. ','.
        .........  ....  .........
        ..........      ..........
        ..........      ..........
        .........  ....  .........

  [i] Existing PHP installation detected : PHP version 7.0.30-0+deb9u1
  [i] Repair option selected
  [✓] Disk space check

  [✓] Update local cache of available packages

  [✓] Checking apt-get for upgraded packages... up to date!

  [i] Installer Dependency checks...
  [✓] Checking for apt-utils
  [✓] Checking for dialog
  [✓] Checking for debconf
  [✓] Checking for dhcpcd5
  [✓] Checking for git
  [✓] Checking for iproute2
  [✓] Checking for whiptail

  [i] Performing reconfiguration, skipping download of local repos
  [✓] Resetting repository within /etc/.pihole...
  [✓] Resetting repository within /var/www/html/admin...
  [i] Main Dependency checks...
  [✓] Checking for bc
  [✓] Checking for cron
  [✓] Checking for curl
  [✓] Checking for dnsutils
  [✓] Checking for iputils-ping
  [✓] Checking for lsof
  [✓] Checking for netcat
  [✓] Checking for psmisc
  [✓] Checking for sudo
  [✓] Checking for unzip
  [✓] Checking for wget
  [✓] Checking for idn2
  [✓] Checking for sqlite3
  [✓] Checking for libcap2-bin
  [✓] Checking for dns-root-data
  [✓] Checking for resolvconf
  [✓] Checking for lighttpd
  [✓] Checking for php7.0-common
  [✓] Checking for php7.0-cgi
  [✓] Checking for php7.0-sqlite3

  [✓] Enabling lighttpd service to start on reboot
  [✓] Installing scripts from /etc/.pihole

  [i] Installing configs from /etc/.pihole...
  [i] Existing dnsmasq.conf found... it is not a Pi-hole file, leaving alone!
  [✓] Copying 01-pihole.conf to /etc/dnsmasq.d/01-pihole.conf

  [i] Installing blocking page...
  [✓] Creating directory for blocking page, and copying files
  [✗] Backing up index.lighttpd.html
        No default index.lighttpd.html file found... not backing up

  [✓] Installing sudoer file

  [✓] Installing latest Cron script

  [✓] Installing latest logrotate script

  [i] FTL Checks...
  [✓] Detected 32bit (i686) architecture
  [i] Checking for existing FTL binary...
  [i] Latest FTL Binary already installed (v4.0). Confirming Checksum...
  [i] Checksum correct. No need to download!

  [✓] man pages installed and database updated
  [i] Systemd-resolved is not enabled
  [✓] Starting lighttpd service
  [✓] Enabling lighttpd service to start on reboot
  [i] Restarting services...
  [✓] Starting pihole-FTL service
  [✓] Enabling pihole-FTL service to start on reboot
  [✓] Deleting existing list cache
  [i] Neutrino emissions detected...
  [✓] Pulling blocklist source list into range

  [i] Target: (hosts)
  [✓] Status: Retrieval successful

  [i] Target: (justdomains)
  [✓] Status: Retrieval successful

  [i] Target: (hosts)
  [✓] Status: Retrieval successful

  [i] Target: (blocklist.php?download=domainblocklist)
  [✓] Status: Retrieval successful

  [i] Target: (simple_tracking.txt)
  [✓] Status: Retrieval successful

  [i] Target: (simple_ad.txt)
  [✓] Status: Retrieval successful

  [i] Target: (ad_servers.txt)
  [✓] Status: Retrieval successful

  [✓] Consolidating blocklists
  [✓] Extracting domains from blocklists
  [i] Number of domains being pulled in by gravity: 149648
  [✓] Removing duplicate domains
  [i] Number of unique domains trapped in the Event Horizon: 126731
  [i] Number of whitelisted domains: 29
  [i] Number of blacklisted domains: 38
  [i] Number of regex filters: 0
  [✓] Parsing domains into hosts format
  [✓] Cleaning up stray matter

  [✓] Force-reloading DNS service
  [✓] DNS service is running
  [✓] Pi-hole blocking is Enabled

  [i] The install log is located at: /etc/pihole/install.log
    Update Complete!

  Current Pi-hole version is v4.0
  Current AdminLTE version is v4.0
  Current FTL version is v4.0

root@pi-hole:/var/log# echo ">stats" | nc localhost 4711
domains_being_blocked 126757
dns_queries_today 8744
ads_blocked_today 134
ads_percentage_today 1.532479
unique_domains 786
queries_forwarded 6133
queries_cached 2464
clients_ever_seen 16
unique_clients 16
dns_queries_all_types 8760
reply_NODATA 9
reply_NXDOMAIN 0
reply_CNAME 10
reply_IP 14
status enabled


That shows that your gravity has been rebuilt successfully, so that problem is fixed.

Are you seeing any difference in the dashboard now?


A post was split to a new topic: No queries shown admin GUI


Can someone try loading this URL?


I get a compression error.

In firefox it says:
Content Encoding Error

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

In Chrome it says:
This site can’t be reached

The webpage at  **http://192.168.xx.xx/admin/scripts/pi-hole/js/index.js**  might be temporarily down or it may have moved permanently to a new web address.


I noticed that URL when doing some debugging in Chrome.

I’m wondering if there’s a lighttpd issue with my install?


If I use wget on the pi-hole (from within an ssh session) it pulls the contents of the index.js file.

If I use wget on a PC client on the network I get an html page that asks if I meant to go to the admin panel.

It would appear ‘something’ on the pi-hole side of things is making a decision about what to send and doesn’t appear to be getting it right.


Bit similar:


I went into /etc/lighttpd directory and commented out the two lines dealing with compression:

#compress.cache-dir = “/var/cache/lighttpd/compress/”
#compress.filetype = ( “application/javascript”, “text/css”, “text/html”, “text/plain” )

Then did a ‘service lighttpd restart’ and voila, things work now.

Ok, so clearly something’s screwy with how my lighttpd instance is handling compression, but given the paltry size of all the files… I’m punting and leaving it disabled.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.